Flashing tools for HP 9100c (rebaged Philips CDD4801)

vbimport

#1

I have HP CD-Rewriter+ 9100c (8x/4x/32x), firmware version H2,1. Many IC on PCB is from Philips, PCB marked as “Philips Hercules 3” and I think it’s rebaged Philips CDD4801. I find Philips firmware v2.5 (file with .cvt extension), but I can’t upgrade drive. Philips FlashTool v3.7.0.0 wrote: “No supported Drives found”, then I tried DOS utilities - Ataflash and Flashhp (FlashCmp). My biggest hope - Ataflash v1.3 wrote “No atapi device found”. :frowning: I tried other IDE port, and other motherboards, no difference for this drive. And finally Flashhp wrote “No Supported Drives found!”. And now I want help. :slight_smile: Have anybody modified FlashTool or Flashhp? Or other flash utility with cvt files format support?


#2

I did it. Flashtool v3.1.0.0 from http://www.mydrivers.com/dir34/d13655.htm (because flashtool.oem in that package is modified for Traxdata) and CDD4801 firmware v2.5 (file v2_5.cvt) from original Philips Flashtool v3.2. But it is strange - firmware version is changed from H2,1 to 2.5, but cd-writer identified now again as HP 9100с, not the Philips CDD4801. :slight_smile: