Flashing ND-6650 with Binflash not working

Hello all,

if have been excessively using the forums search as well as google but could not find a solution.

Having a NEC ND-6650A in my Dell Inspiron 500m (replacing my old DVD-Rom) it has been running without problems so far. Today I wanted to update its firmware to 1.62 (Original version from liggydee.cdfreaks.com).

The specs:

The NEC has got the firmware 1.23, DMA is ON (secondary channel), it is recognised by Binflash/Nero InfoTool as “_NEC DVD±RW ND-6650A” (with 5 blanks between _NEC and DVD).

The Problem:

When trying to flash with Binflash (1.27 from micheldeboer.nl), after having accepted the “legal disclaimer”, Binflash refused to flash the firmware with the comment:
“Cannot determine whether flashing your drive with this firmware is safe. Continueing here is very likely to DAMAGE your drive. Are you really sure that you want to continue? If unsure say NO”,
following “Firmware is for a different drive” after having pressed NO.

I have also tried to flash 1.42 (orig) and 1.62 (mod by Liggy) all with the same result.

Has anybody an idea what the reason for that could be, or (even better) any solution?

Thanks in advance,

firesan

i would imagine this is just a warning, and all should be fine, but if you are completely unsure about this dont go ahead with it. also make sure you make a dump of your current drive firmware

Can anyone confirm this?!?

The Binflash-Tutorial by Liggy does not say anything about that
(http://liggydee.cdfreaks.com/page/how2flash/binflashgui), nor did i find anything about that warning in the forum or google.

Binflash recognises my drive to that extent, that I did not have any problems dumping the firmware of the ND-6650 to my computer.

One assumption by this time:

Could it be the “wrong” recognition through Windows in means of those 5 blanks in between _NEC and DVD ("_NEC … DVD±RW ND-6650A")

well as long as your sure its the right drive and the right firmware, you should be ok.

Looks like something is not recognized correctly in Binflash here. :confused:

If you’re really updating from one 1.** firmware to another 1.** firmware, everything should be fine. But I’ll try to investigate this issue now. Looks like the master/slave code is not working the way it should.

Liggy there is definitely something very wrong with the latest (1.27) flasher.

First I flashed my 6650 twice 1.62->1.23->1.62 with necflash 1.24 and everything went okay. No warning or error messages.
Then I tried the same with v.1.27. I managed 1.23->1.62, but not back to 1.23. Yes, I got the same warning as TP, but ignored it.
Now my drive is not recognized anymore. I only get IDE bus failures. See attachments.

@haveacigar, don’t know what to say, but sometimes it’s better not to say anything at all. :a
.



sorry, i just assumed it would be ok… i wont assume in the future

I just found a bug in the master/slave recognition of 6650 drives. I hope it is fixed with version 1.28 now.

Update.
When lappy refuzed to start with drive in, I shut down and removed the drive. Booted into windoze and reinserted drive. No new hardware or any other action was displayed.
Restarted lappy (with drive in) and now everything loaded okay… :smiley:

@haveacigar, sorry if I overreacted. But when it comes to flashing it’s better not to advice when you don’t know what’s all about.
Hope you accept my apologizes. :wink:

sorry if i sounded like i was being offencive, i know i shouldnt have just assumed with firmware, is my fault.

Confirming ND-6650 bugfix in new BinFlash v.1.28. Thanks Liggy. :bow:
.


bugfixed BinFlash v. 1.28 working for me as well, thanks a lot for the fast replies/response :bow: :flower:

@haveacigar/pinto2:
good, that everything is back on track :slight_smile: