Flashing LiteON 812S with Codeking firmware

Trying to use the burn adjusted firmware US0N by codeking that is contained in an executeable flasher. I get an error window saying “No matched drive detected!” It detects my Liteon DVDROM LTD163 as 1-0-1-0 F. 2-0-0-0 E: is blank. KProbe identifies my 812s as 1-0-0-0 SOHW812S US0F (what do these numbers mean, the 1-0-0-0?) My LTD163 is identified by KProbe as 1-0-1-0. I’m running WinXP Pro with SP1. I’ve burned a data DVD with the new 812S already.

Can I run the executable in WinXP?

Help would be appreciated
Thanks!
Ed

Welcome to the CDF forum.

In the case of US0N, the flash utility looks for a 812S drive attached to your system. I believe the flasher uses ASPI to detect the drive. Do you have the Nero InfoTool? It has an ASPI tab that tells you if the ASPI is working properly (see attachment). Kprobe 1 will switch to STPI to detect your drive which is why it might be detecting it and the flasher is not.

The numbering is the location of the drive. 1-0-0-0 is secondary master and I think 1-0-1-0 is secondary slave.

The flasher works fine in windows XP. Lets check your ASPI first and see if this is the problem…

Edit: If you dont have Nero InfoTool you can get it from here.


Also, I just found this [thread=96716]thread[/thread] which many help with your problem…

C0deKing,

Thanks for the reply and the pointer. I looked at Nero InfoTool and it matches exactly the pic you posted. I’ve tried removing ASPI with ForceASPI’s killaspi.bat. KProbe2 uses SPTI and shows only 2-0-0-0 with no drive ID. I removed the other LiteON LTD163 with no change. I put the LTD163 back in as master with the 812s as slave. Using SPTI, the LTD163 shows as 1-0-0-0 E:… LTD163…, and the 812s shows as 2-0-0-0 F: with no ID. Each time I try the US0N exe, it says “No matched drive detected”.

Reinstalled ForceASPI. KProbe2, using ASPI shows the 812s as 1-0-1-0 F:…812s… as expected. Switching to SPTI, the 812 doesn’t show up (2-0-0-0 F: with no ID).

XP sees the drive and the DVD disc loaded in it. Anything using ASPI can see the drive correctly. Seems like SPTI can 't see the drive. Does the US0N exe rely on SPTI? Tried using firmware.exe (LtnFlash?), it can’t see the drive, reacts the same as KProbe2 using SPTI.

I’m running XP SP1 on a Gigabyte 8KNXP and have turned off all other IDE, raid and SATA controllers in BIOS, except for the primary and secondary IDE.
I’m also not running any virtual drives. This is a fairly fresh install of XP.

Thanks for your time so far. Should I try the OEM firmware? I just found this forum and read great things about your “enhanced” firmware, so I’d like to try it out.

Thanks again!

Sorry, I was away from my PC today.

Gosh, you’ve been very thorough. I’m intrigued by the fact that your drives are E: and F:. What is drive D?

I’ve had XP screw up the driver install before. Have you tried deleting the 812S in device manager and then rebooting. If after the drive is detected it suggests you reboot again, make sure you do it staight away and not later as the prompt allows you to do.

The OEM flasher will probably just do the same thing but certainly give it a try.

That’s quite alright, I’ve been away myself.

My D: drive is another partition of my main drive, It’s a 200G IDE.

Good news though, it worked! I don’t know exactly what I did. I was getting frustrated and removed and reinstalled ForceASPI a couple of times with the same results. Rebooted several times out of frustration. I then started KProbe2 and noticed that for both SPTI and ASPI, the 812S is recognized. I might have a flakey drive though, with the 812S as master and the LTD163 as slave, NeroInfo tool says that DMA is not enabled for the 812S, no matter what I do. I switched the 812S to slave with the LTD163 as master, and it shows both as DMA enabled. Also, when I run KProbe scans, sometimes after finishing 99% of the scan, I get servo errors for a long time until I stop the scan (is this normal?) I think that your idea of removing the 812s from the device manager is a good one, though I can’t really verify it now. Seems like rebooting Windows several times is the equivalent of smacking your cheap TV on the side to get better reception :slight_smile:

Now, I flashed my 812S with the burn-adjusted US0N and did some scans. The improvement is very pronounced, I don’t know if your firmware would affect this (I’m pretty new to DVD burning). Previously, I would get a somewhat large area of PIs around 150 with a final average of about 18. I think this is still considered good, but the area in the beginning disturbed me. Now, the scan is smoother all across the board with an average PI of 2.2, max of 45. This is with Verbatim MCC002. I’m still a newbie, but it sure seems like a marked improvement.

The hype surrounding your firmware seems to be well deserved. Thank you for your hard work on the firmware and especially your time in assisting me with my problem. Still wish I knew exactly what I did to fix it though.

Thanks… Ed