Flashing Ldw811s using Pata-Sata adapter

Hello

i have connected my Ldw811s to the Sata port using a pata-sata adapter,
after i flash the bios using LtnFW,
the description in Bios change to “LiteOn DVDRW LDW81”.
i believe it used to be “LiteOn DVDRW LDW811s”.

tried to flash with the drive connected as IDE,
tried to flash using LtnFW with update BootCode,
tried clearing the CMOS setting,
still the same,
anyway to get the proper description(in bios) back ?

using Nero toolkit or DvdInfo, the description is OK,
only bios have problem,
have not burn any disc yet

I wouldn’t worry about it. In my BIOS, my drive gets cut off and displayed as “83” instead of “832S.” Why it would do this on you when it didn’t before is indeed strange, but it doesn’t sound like any flashing problems (if it was the result of any form of misflash, things would be much worse than 2 lost characters)

You didn’t mention if you were having any trouble with the drive, or if the FW was actually flashed.

I have a modified version of a LiteOn flashing tool that was made for flashing SATA drives on SATA controlllers, it may or may not be helpfull to you depending on your particular controller. Each controller is different in the way it does or does not allow the ATAPI drive commands.

Anyway, if you want it you can PM me with an email address and I’ll send it to you. Of course it requires .bin files for flashing. I’d be interested in knowing what controler you are using, and whether other tools like KProbe2 and CDSpeed are working.

You may also want to read about the 52A8S drive in my sig.

i have remove the sata adapter (using SIL3112),
just burned a DVD-R (@2x) using IDE PriMaster,
cannot even recognise the disc after burn.

run a Nero DVD-Speed test,
all the result comparable to the test i done a few days ago,
except that the drive is making funny sound intermittenly when reading.

i am thinking of re-flashing using mkflash v1.80.1,
but will the write quality drop after flashing wi MKflash ?

thanks inadvance for any input

The flashing method used has no bearing on write quality, it either works or doesn’t. Your trouble sounds more like media or drive troubles.

the media i just burned was Fuji Taiyo Yuden 4x(Made in Japan)
anyway, since day 1, which is 3mth ago,
my drive have yet to deliver good K-probe result,
(except on 2.4x using MMC dye)
have tried more than a dozen media including TY + & -,

will do the re-flashing now…

O my god…killed my drive when flashing via mtkflash,
bios always hang at “Detecting IDE drive”
have to remove the power cable inorder to boot up into OS.

my drive is totally dead,
no led, cannot eject

anyway to revive it ???

what i did:
bootup using floopy (w/o cdrom driver),
go to C-Drive (mtkflash & bin file inside C:/temp folder)
and execute the backup command,
then execute the write command,
(mtkflash 1 W /B orig.bin)
then reboot.
My Sys:
Sata 1- Harddisk1 (c/d/e/f-drive)
Sata 2- Harddisk 2 (g-drive)
PriMaster- Ldw811

It should be recoverable with mtkflash, try it again and report any error messages. Be very sure you are using a good binary FW file.

the problem is that i cannot connect the drive to my PC now,
else it will hang at the “Detecting IDE” part when booting up…

maybe can boot if i disabled the ide bus in bios, (didnt try yet)
but also cannot flash in this way rite ?

btw, the backup copy is only 64kb,
while my bin is 1024kb,
does this mean anything ?

should have d/c all my sata hdd before flashing !!

Some boards have a switch to bypass that step, (esc, insert, etc), or you can just let it sit for a few minutes and it’ll resume. If all else fails, just wait till after POST before connecting the drive power cable.

btw, the backup copy is only 64kb

Oops, I just saw that, no that’s not right.
MTKFlash should show a progress indicator for 16 banks of memory when reading or writing, if not then the process is not complete.

In this thread, you will find all steps to recover your drive:

http://club.cdfreaks.com/showthread.php?t=84975

i am back in business…Yep…
my Ldw811s is revived!!

THANKS for all the help !!

manage to re-flash using the mtkflash command (without /B)
drive can be detected and eject button works again.

one qustions,
will the previous wrong flashing (using /B),
affect the write quality ?

Nope. No adverse effect whatsoever; you’re fine. :slight_smile: