FlashFix

Version 1.0.0.4 has been released.

Improved compatibility with latest Liteon drives and latest flash utilities.

This is a universal version for both the old and new Liteon flashers.

Now supporting ver 1.043 to 1.051 of the old flasher and ver 1.0.0 to 2.0.4 of Xflash.

As of now, Flasfix does not support QS0E7 (for LTR-52327S)

Download here:
http://digi.rpc1.org/flashfix.htm

Have fun but be careful :wink:

Edit:

Newer version now out (1.0.0.4)

cool just what we need with the 0G firmware problem i’ll try this.

thx

Thanks a lot!.

If anyone wonders what this could be used for: Removes the drive and firmware version check from the windows .exe flashers.

Useful for:

-Going back to older firmware versions by using the windws .exe flashers (FS0G to FS0F is on example that many users have requested).
-Converting OEM drives to real Lite-On drives.

You’re welcome! :cool:

Thanks for the utility mango!
Anyway, it doesn’t work for the XS0X firmware that I have :slight_smile:
I tried to flash it over the XS0Z… flashfix says - OK it is patched. But when I run the XS0X windows flasher - it still says that I have newer firmware. Finally I extraced the BIN from the exe flasher and flash it under DOS :slight_smile:

:bow:

Thanks. This is what I was looking for my 811s

As you may have read in another posted, a botching with mktflash has left the system not detecting 411s at startup. Mktflash only works because it accesses the IDE port directly — I assume that this is a windows program, even if it still bypasses some of the stuff, its still using the SCSI ID that an aspi assigns, and you can’t just point it to a IDE port. I’m just wondering cause who knows, maybe an official flasher could do something to bring it back to life mktflash provided it would work.

It worked on the 811s. I have flashed back to HS0E, but my drive still refuses to read the DVD+RW that came with it in the box. Bummer!

Answered my own question, no ID, won’t work. Just wish I’d been aware of this software a couple days earlier, could have avoided this.

bump

Was on page2 already.
Great tool!

Originally posted by Thorz
It worked on the 811s. I have flashed back to HS0E, but my drive still refuses to read the DVD+RW that came with it in the box. Bummer!

Shouldnt that have fixed it?

I don’t think he’s tried a different +RW disc yet.
As he doesn’t seem to have any other major issues I’m thinkng that the disc is toast.

Originally posted by Ssseth
I don’t think he’s tried a different +RW disc yet.
As he doesn’t seem to have any other major issues I’m thinkng that the disc is toast.

The disc is not toast. I have been in a PC store here in town and have formated the CD+RW there in another burner that recognised perfectly the disc. I cam home and the $#@%@!!! 811S refuses still to see the disc. What a waste of time.

Originally posted by Thorz
The disc is not toast. I have been in a PC store here in town and have formated the CD+RW there in another burner that recognised perfectly the disc. I cam home and the $#@%@!!! 811S refuses still to see the disc. What a waste of time.

It worked on the 811s. I have flashed back to HS0E, but my drive still refuses to read the DVD+RW that came with it in the box. Bummer!

Is it a CD-RW or a DVD+RW you are talking about?
If DVD+RW, try to full format/erase it again.

BTW, can you “se” the disk with Nero Info Tools?

Originally posted by pinto2
[B]Is it a CD-RW or a DVD+RW you are talking about?
If DVD+RW, try to full format/erase it again.

BTW, can you “se” the disk with Nero Info Tools? [/B]

CD+RW.

The problem is that the drive doesn’t recognise that there is something inside it, so basically how can you format if it thinks that there is nothing inside?

Uninstall any packet writing software like InCD or DirectCD or DLA.

What in the world is a CD+RW?

Originally posted by Thorz
It worked on the 811s. I have flashed back to HS0E, but my drive still refuses to read the DVD+RW that came with it in the box. Bummer!

Dewd, you had us believing it was a DVD+RW…

Originally posted by Hypnosis4U2NV
Dewd, you had us believing it was a DVD+RW…

Ooops! My fault guys. DVD+RW I mean :smiley:

No packet writing software here dhc014. Thanks for the tip.

Thanks ALot! This worked great for my 411S and 811S. I’m back to the firmware before XMAS and testing at 2.4X right now!

THANKS AGAIN!!