Flashed to 1633S Said Successful > Nothing Working



Hi :

I have a Sony DW-D22A that came with the BYS1 firmware.

I successfully upgraded to a SOHW-1633S with the BS41 firmware found here : BS41 - patched - crossflashing.

Now the problem is I cant open the drives door.

So I manually opened it with a pin and put in a CD and nothing happens at all.

Even though Firmware Flash said successful looks like somthing has went wrong .

Did I just create myself a paper weight or is the something else I can try to get this working again?

Did I back-up the original firmware-NO .Cant believe I did this but maybe someone might be able to walk thru getting this fixed.

When I tried to flash back older version I got the message [can not flash drive contact Vendor]

Thanks for any ideas or help.



Boy sure wish someone would have a look at this and possibly post some ideas.

As it is now drive is reconized in Device Manger as 1633S but when I click to open it in My Computer it just hangs and doesnt respond.

Also door will not open and Led Light just stay on .

Any ideas thought suggestions appreciated.



Sounds like a Bad Flash sorry to hear it but have a read of This and also Here and I think there is some info about it in the Lite-On Thread as well, it’s happened to a few people so using the Search might give you some help as well. :slight_smile:


Thanks coathi:

I wish I could figure out how to recover from it.

From most of what I read if I understood it correctly that a bad flash wouldnt be reconized in Bios.

My drive is reconized in Bios and XP as a 1633s so not positive yet if its a failed flash.

I have read and read most of the things you pointed to but its still kind of greek to me.

Thanks Again:Snowus


Snowus I was hopping there was something in the Links to help you recover the drive, the Firmware you used might of been incomplete of it didn’t Flash correctly so it shows up as 1633 but the drive is still not working . One thing I have never tried to do is crossflashing a drive so I can’t talk from experience, I can only give you a few suggestions, but have you tried using FlashFix on your Firmware before you try and Flash it back to a older version ? Also try using Mtkflash and try and Flash back to a Sony with the Firmware your drive came with even if you don’t have the original, download the same version and try and use it, On the link where you download Mtkflash there is also a very detailed Tutorial on how to use Mtkflash. Hope it’s of some help to you to recover your drive.


Thanks coathi:

I tried to flash it back and nothing has worked so far.

Here is where I am at as of this writing:

Downloaded & unzipped mtkflash version 1.80 saved it to >>>>>>>>>C:\firm
Downloaded & unzipped DW-D22A_BYS1b.zip saved it to >>>>>>>>>>C:\firm

Created a boot disk from NIL Pioneer DVD page as described.

Changed the Boot sequence to Boot from Floppy Dr.

Inserted the Boot Disc restarted computer.

Chose minimal Boot as described .

That brings up A Prompt: A:>


Now I have tried to type in the path I saved files to which should be:


That brings it to the C:>

I then try and type in C:\ firm .I have tried this several ways with spaces etc and it will not allow me to enter the \ key.

C:\ firm but for some frigging reason I can type the backstroke key \\

When I try to enter backstoke \ I get this ~ at the Dos Prompt=WTF

I have tried to figure out why I cant simply enter a backstoke \\\ at the C prompt to continue ?

It seems like I have followed everything else and thought I was pretty much ready to try and reflash drive then this damn curveball comes into play!!!

I even switched to a PS2 keyboard thinking my wireless keyboard might have something to do with this>> Samething happens with PS2 keyboard type in a \ and get a ~ .

Anyone have any ideas why I cant just enter a \ @ C:> Dos Prompt?

When out of Dos Mode it works just fine.

Kind of on TILT right now maybe a break would help settle me down.



Snowus if you are going to Flash DVD drive from you HD make sure it’s formatted to Fat 32 , if you are running XP on a NTFS file system, DOS will not work! it will only work on a Fat 32 Formated HD. I don’t know why you can’t use your “ \ “ it sounds very unusual, From the site you down loaded Mtkflash follow the link and download DOS 7 and put Mtkflash and your firmware on a DOS 7 Boot Floppy and Flash your drive from the Floppy, that way you don’t have to use your “ \” .


Thanks coathi:

I have fixed most of the little problems was able to navigate to correct folder and thought yeah here we go.

Typed in the the Flash Code and was presented with the following:


Any ideas how that happened?



Thanks coathi:

I have fixed most of the little problems was able to navigate to correct folder and thought yeah here we go.

Using mtkflash 1.80 BYSI.BIN both in C under C:\liteon\

Typed in the the Flash Code:

C:\liteon\mtkflash 3 w /b /m bys1.bin

and was presented with the following:


So I tried it again C:\liteon\mtkflash 3 w /b /m bys1.bin
and got this:

FLASH TYPE:Unknown Flash Memory


I must be doing something wrong any ideas on what it might be?



Small update on this:

Tried using mtkflash 1.80.1 with bys1.bin

mtkflash 3 w /m bys1.bin

It went thru with updating:

Updating Finished! (0000)

This only took like a minute or so isnt there more to it?

Please reboot PC.

But its still isnt working



Moved from Newbie to LiteOn forum, maybe some pros over there can assist.


That works for me :bigsmile:

Thanks Ssseth


Updated on some small progress.

Well I have made some progress on this.

As suggested I downloaded another file as file was possibly corrupted and not finishing .

Placed the new bys1.bin & mtkflash 1.80.1 on a floppy:

mtkflash 3 w /m bys1.bin> on a floppy disc

Booted with 98 disc switched to file disc after 98 boot loaded.

It updated 15 banks with checksum of (939) think that was the total number.

The Drives Led has now comes on and it is reconized in Bios & XP
[As CD-Rom] but the Led is constantly on and drives door will not open.

So although its a step in right direction [YAHOOOOOOOOO] it is still not totally revived.

Guess I could manually open drive and see what happens if I load a DVD in there.

Tried manually to open[with paper clip] place DVD in and nothing happens[just sits there]

Also when I double click drive in Device Manager it also hangs but eventually opens drive properties and says its working fine…LOL

Prior to this updated post if I had DVD powered up computer with IDE 2 connected the Bios would just hang at detecting drives.

Now it detects drive and loads everything.

Any suggestions on what I might try next?



Thanks to heck of alot of Googling& seraching thru this Forum I think I have it fixed.

The last thing I did to get Drive door and Led to work correct was this.

I jumpered the 2 of the 6 pins located NEXT to the Cable Select/Slave/Master Set-Up.

With Drive set to Master on 2nd IDE Channel and other pins jumpered I booted with 98 disc.

I then ran the mtkflash /bin file floppy once it was done I shut down PC and took out the jumper.

I then rebooted and couldnt believe it , seems like its back up and running.

Why this worked I have NO idea, but I read some posts on people doing this so I gave it a shot.

Burned a few CD-Rs and DVDs and for now looks ok>>Knocks On Wood Twice]

Only thing that is not working as before is when I tried to watch a DVD with Power DVD 5 it said “Disc with unsupported Format in G.”

I have tried numerous discs, store bought DVDs burned DVDs and they all say the samething when trying to watch in Power DVD humm interesting.

Oh well for now I can live with this.



Good to hear you fixed it! Nice to see someone do some leg work on their own and come up with some sort of an answer. :iagree:


Backing up your firmware with Mtkflash

Use this command line to make a single file binary backup of the firmware:

MTKFLASH X R /M /B anyname.BIN

and to update your firmware:

MTKFLASH X W /B filename.BIN

only instead of the X should be:

1 - if the drive is master on primary IDE

2 - for slave on primary

3 - master on secondary

4 - slave on secondary


Thanks it took awhile but everything is now back up running fine.

Oh yeah the problem with the DVDs not working were Power DVD was trying to run them on my G Drive>>I dont have a G Drive so changed it to F and DVDs worked perfect.