Flashed 3500A Trashes My MBR!

vbimport

#1

Hi

I flashed my NEC 3500A yesterday with the Dangerous Brothers RPC1 fix. (3500RPC1.BIN based on latest firmware version 2.1A.) This seemed to work but subsequently Windows (2K) failed to boot. It got stuck at the initial Windows logo screen, with the progress indicator about 3/4 of the way across.

I disconnected the DVD drive but I still could not get it to boot. I then tried the Windows 2000 installation CD to do a repair. I got errors like “Disk I/O Error…etc.” and “Failed to ArcRead boot partition to check for a signature”. I tried the recovery console at this point and I was able to get in. The most obvious thing to try seemed to be FIXMBR so I did this, and was able to boot into Windows successfully on the next try.

When I had been doing the flashing earlier, there was one time when I didn’t shut Windows down cleanly. I thought that perhaps this was responsible for trashing my MBR and the DVD was not at fault, so I tried reconnecting the drive but the boot failed again. I had to disconnect the drive and fix the MBR again.

Next, I booted into DOS via a boot disk and reflashed the DVD to the original firmware (which I had backed up earlier). However, I had the same problem and had to go through the same process again. I haven’t tried anything else and the drive is now disconnected. I have had no problems booting since last disconnecting the drive and fixing the MBR (I have rebooted a few times since then).

So it seems like the flashing of the drive has resulted in it causing the MBR to get broken during the boot process. As I say, this even happens with reverted firmware. What sort of thing is likely to be going wrong to cause this and is there anything I can do about it? Did I need to set something in my BIOS or something. (Its an Abit NF7S based system if that’s any help.)

Some more details that might be relevant:

  1. I tried to flash in DOS initially. I was able to backup my existing firmware using the command “nec3x00a -sec -sla -out BACKUP.BIN” but the attempt to flash the new one with “nec3x00a -sec -sla -flash 35000RPC1.BIN” failed with error “ERROR: image type mismatch”.

  2. A bit of googling suggested I might be more successful with the Windows flasher, though in retrospect this seems odd as I would expect the ‘simpler’ environment to be more successful.

  3. Anyway I booted into safe mode to run the Windows flasher. This seemed to work fine. I’m not sure whether doing it in safe mode was the right thing to do - my rationale was that there was less chance of anything running that would interfere with the flashing process.

  4. I think I managed to boot successfully into Windows on one occasion after this, but I would not swear to it.

I would be grateful for any ideas or explanations about this. It would be nice to recover the drive, but I am not too bothered if I have toasted it - I was just relieved my system wasn’t trashed! I am bothered about introducing instabilities into my Windows installation and, as much out of curiosity as anything, I would like to understand what might have happened. I would also like to find out if there is something different I could/should have done so that I can avoid similar problems if I ever attempt this again.

Thanks

Bob


#2

This flashing method will never ever touch the MBR!

Your OS installation acts weird because there are other issues…

PS: Do you know what the MBR really is (for)? I think you don’t, from the sentences you have written here. :rolleyes:


#3

I didn’t suggest it did. I think you may have misread what I have written. This is probably my fault for not being a bit more concise but I wanted to include all information that might be relevant.

To reiterate, the problem is that after the drive was flashed, the MBR becomes corrupted whenever I try to boot with the drive attached to my system. I did not say that the process of flashing itself touched the MBR.

Look, I’m not claiming to be an expert, but I do have a reasonable notion of the role of the MBR. Perhaps you could suggest what these “other issues” could possibly be? Are you suggesting there was not really a problem with my MBR? If so, how do you explain the observed behaviour? (Please note: I am willing to accept there may be other issues. It’s just that I have no evidence or idea of what they might be.)

Here are the facts again:

[ol]
[li]I flashed my DVD drive.
[/li][li]Boot subsequently failed.
[/li][li]Detaching the DVD drive did not solve the problem.
[/li][li]Investigation suggested a problem reading the boot partition (see the error message I saw when attempting a recovery using the W2K installation CD).
[/li][li]FIXMBR seemed to fix the problem, but only as long as I did not reattach the drive.
[/li][li]Reattaching the drive caused the problem again.
[/li][li]Reflashing to original firmware does not help.
[/li][/ol]

If you want to reply again maybe you could try not to be rude. This was my first post here so please cut me some slack.


Bob


#4

Wasn’t my intention, maybe it came wrong to you because my mother tongue isn’t english.

Anyway, I still think this issue is made/initiated by other things.

Have you checked the Event-Viewer?
Could you run Everest on your system?


#5

Fair enough. No harm done.

I checked the event viewer and there was nothing obvious.

I’ll look into Everest - it’s new to me so thank you for the suggestion. Is there anything in particular I should look for?

Thanks.


Bob


#6

By a chance, have you replaced ide cables??


#7

No - I haven’t changed hardware at all for a while. The only time I have touched the IDE cable is to disconnect the drive but that was after all this started happening. It had all been running without a hitch until I flashed the DVD drive. I would really like to get to the bottom of this. I understand what you are saying about there being some other issue with my system because, even with my limited knowledge I can see that this behaviour is bizarre. But whatever it is, it only manifests itself when I connect that drive and the effect is to damage the MBR. At least that’s my assessment based on the error messages I saw and the fact that FIXMBR works.

I have a CDRW drive on the same IDE - the DVD was the slave. The CD is working fine. Do you think it is worth trying to install the DVD alone as master?

Also I will still try Everest - I won’t be able to do that until later.

Thanks.


Bob


#8

OK, have you done the usual tests using Spybot, Ad-Aware and a reliable Viruskiller yet?

You could try to install the DVD alone. Worth a try.


#9

Well I’ve got my drive back again!

In my first post I said that I thought I had managed to boot successfully once after flashing. I remembered tonight that this indeed was the case and that the other thing I did was to install DVD Region Killer. I forgot all about this as it was the last thing I did in a hurry before rushing off. When I clicked restart after installing it I had to leave my machine for a few hours. It was when I came back to it that I found that the reboot had got stuck, but then I was in a panic and forgot all about the software I had installed.

Anyway, when I remembered this tonight I uninstalled the software, reattached the drive and we now seem to be back to normal.

This still seems odd to me as I would not expect the software to come into effect until Windows had booted, but the problem was occurring prior to that.

Anyway, I am back to the beginning now. I would like to remove the region locking; it seems that I can flash the firmware without problem after all (I am currently back to original); but if DVD Region Killer causes this to happen, there is not much point.

Oh well. At least someone might find my experience useful in future.


Bob


#10

Yup, glad you found a solution.

Tools like AnyDVD, Regionkiller, DVDGenie etc etc can give such issues. I think it’s mainly because of the chipset/IDE drivers used.