Flash Error -ASUS DVD-E616P3! Help!

I recently bought Compaq presario SR1010Z, which came with ASUS DVD-E616P3 with version 1.04. I tried to update the recent flash 1.07 and got the error “drive name does not match”.

I tried to use the latest firmware from the http://tdb.rpc1.org/#E616P3, it did not work. Interstingly my physical DVD drive says ASUS DVD-E616P3 but in the driver details in the XP says ASUS DVD-E616P3H.

Please help.

Thanks for your time.

A flash error is normally a misflashed drive.
Be happy the prog prevented you from doing that.

I have the same drive with the same problem. Compaq seems to have there own firmware slapped in there and I haven’t found a way around it. None of the regular or OEM firmware flashers I’ve found work. The drive reports that it’s an ASUS E616P3H with firmware 1.04. The E616 info I’ve found says nothing of this version that has an “H” added to the end of it. It appears that all other 616 models don’t go below firmware 1.05 either. Anyone having anything on this one?

Also, does anyone know where there might be ASUS binary firmwares? Or a way to extract them from the flasher?

Thanks

You can find it here: http://tdb.rpc1.org/#E616P3

Those are among the firmwares I’ve already tried. None of them will flash the drive. They’re run as executable firmware flashers and I’m looking to see if maybe a binary version of those firmwares that I can manually flash the drive with will work. I haven’t found any binaries for this drive nor utilities to make them. Don’t know if you have a lead on that…

Thanks for responding