FLAC support

vbimport

#1

Okay how do we get FLAC support for NeroLINUX? This is pretty much a deal breaker. I bought NeroLINUX from it’s reputation and my experiance with it when I was part of the Windows Minions. K3b I’m not satisfied with and burning iso with Nero works great. But since 99% of my collection is all FLAC Nero may loose many potential Linux customers, including myself.

So…

Where’s the plugin, or how do we activate it’s support for FLAC?


#2

Have just got this to work, after a lot of experimenting. I am no expert, so anyone please feel free to correct.

First you will need the flac package installed. To test, type flac --help and metaflac --help at a console. If you get a sensible output, they are installed, if not go to the flac website, download & install.

In Nero Linux go to File>Preferences and click the File Types tab.

Click Add File Type, and in the box entitled extension, type .flac
In the track type box, select audio.
In the Format select little Endian.
Under filter name type flac -dc "$file"
Under Detect Size, type metaflac --show-total-samples "$file"
In the last box type ((getpos(1,1)+22050)/44100)752532
Click apply. This worked on my Mandriva 2006 system. The figure 22050 adds 0.5 seconds to the track time (22050/44100). Without it I found I would get an annoying “pop” at the beginning of eack track except the first. You may be able to reduce it to a shorter period, try experimenting on a CD-RW. Good Luck.


#3

Yep this should work fine :stuck_out_tongue:


#4

Great, I’ll give it a shot, Thanks