First build with USB 3.0 / first USB 3.0 flash drive /issues copying data

vbimport

#1

I finished my first desktop build I built myself back in April.

It has 2x USB 3.0 ports in the back and I added an Anker 2 port USB 3.0 3.5" front bay upgrade that connects to the mobo’s front panel usb3 lead.

I just got my first and only USB 3.0 flash drive last month and when connected to either front or back USB 3.0 ports, Windows 7 gives me errors when copying data to it.

The first error said the drive was dirty and asked to scan the drive for errors. I did that and it said nothing was wrong.

Afterwards, when copying data to it the error says the host drive is no longer available and the copy process terminates early.

Google wasn’t much help and the apparent fixes didn’t work for me.

On the other hand, the drive works fine on USB 2.0 ports.

This build is the only PC I have that has USB 3.0.

OS: Windows 7 Home Premium SP1 x64
Mobo: ASUS M5A97 R2.0
CPU: AMD FX-6300
RAM: 8GB DDR3 1600
HDD: WD 1TB Blue
GPU: Gigabyte AMD Radeon R7 260X 1GB


#2

I forgot to mention that I had formatted the flash drive as exFAT. NTFS also gives me the error.

I always used the quick format option in Windows.


#3

What size is the flash drive?


#4

128GB Kingston

This is the drive.


#5

I’d suspect the USB-3 driver. There may be an updated driver available from Asus, its probably an NEC controller. Anyhow you should see probably 4 entries in Device Manager called “USB-3 Host Controller” or the like.


#6

I’m sure it’s the latest version. I have version 1.16.12.0. What I see in device manager are two instances of ASMedia XHCI Controller.

ASUS has two older versions at their site for my mobo. V1.16.10.0 &
V1.14.3.0


#7

I was fully able to copy 24.1 GB worth of MakeMKV -> Handbrake mkv files in around 15 minutes.

What I did was uninstall V1.16.12.0 of the USB3 ASUS driver and then install V1.16.10.0.


#8

Glad you got it working, drivers are a pain sometimes and the only thing to try is going backwards sometimes to get it fixed.


#9

60s * ~15 min = 900s
24.1 GB = ~24,100 MB

241/9 = ~27 MB/s.

According to Amazon reviews, that’s about normal for that flash drive over USB 3, so you may have found a good workaround for the problem. Nice. :slight_smile:


#10

The visible write speed was 18.5 megabytes/second. That’s where it leveled off at.

Many criticize that drive model in reviews saying the drive is slow and writes at around 9 to 10 MB/s and Kingston always chimes in to say that they market the drive as an entry level USB 3.0 flash drive and refers them to their performance model flash drives.

BTW, USB 2.0 speeds were between 16 to 17 MB/s for the same data.


#11

How about read speed for the drive on USB 3?


#12

Read speed was 30 to 35 MB/s over USB 3.0


#13

Actually the read speed started at 40 MB/s and at the end of the transfer it ended at a minimum of 36.9 MB/s


#14

Wouldn’t you know it, I’m back to where I started.

I restarted the computer and attempted the same copy process and it terminated early and prompted a scan to find any problems. It never finds anything.

I tried all 3 of the USB 3 drivers, restarting after each install, still the same.


#15

If you’re doing all this testing with the same drive, it might be time to change that.


#16

Yeah, the drive may be faulty. I’ve got 4 other flash drives, but they’re all USB 2.0.

I wonder if I should dive into a portable USB 3.0 HDD. Either this one or that one.


#17

NewEgg and Amazon frequently have decent USB-3 thumb drives on sale. 64GB is the current sweet spot for price vs performance. Portable HDD are fine, but generally slower.


#18

What would be the good brands of flash drives to look for?


#19

I have had very good luck with Adata and Kingston
I just got a couple Sandisk that seem to be performing well so far.


#20

What models & capacity are they?