Firmwares (finally) online again :)

vbimport

#1

took some time but theire online again :smiley:

Original Asus CRW4816A Firmware V1.0
Asus CRW4816 Firmware V1.11

Original Asus CRW5224A Firmware V1.0
Asus CRW5224A Firmware V1.10
Asus CRW5224A Firmware V1.20
Asus CRW5224A Firmware V1.35

Asus E616 DVD ROM Drive Firmware V2.0

all firmwares are in .bin format so you guys shouldnt have any troubles flashing the drive with MtkFlash
I tested all files that i have on my site and i found them working without any problems.
if you nuke your drive its not my fault :bigsmile:


#2

Neat, thanks!


#3

> all firmwares are in .bin format so you guys shouldnt have
> any troubles flashing the drive with MtkFlash

Thank you thank you thank you!


#4

So you’re saying that we can flash those firmwares using MTKFlash on Asus CRW 5224A? Till MTKFlash 1.80, the flasher doesn’t recognize my chip.


#5

I found this flash utility on rpc1.org but I haven’t tested it.


#6

It doesn’t work to downgrade the fw 1.0 on my ASUS 5224A.

Did you have better luck, Parker? And how you did it… if you did it?


#7

Hi, thanks for the firmwares.
I’m also having problems trying to flash my asus 5224A. Mtkflash doesn’t work and the asus utility accepts only files with afs extensions. I tried changing the extension from bin to afs but evn though the utility recognizes the firmware as being 1.0 it doesn’t want to flash the drive because it says it’s not an asus file system. Does anyone know what’s the difference between afs and bin? Or any other utility that can be used to flash the asus with a bin file?


#8

Please, help me with asustek crw-5232as!

operating system fails at the moment of flashing, so my flash erased and I can’t see drive in computer setup, dos, and windows. Drive is dead.


#9

I have a new Cendyne drive 522452AU firmware ver 1.20 which is a rebadged ASUS 5224A . I got this drive for free in mailin rebate without any warranty. I have upgraded it to Cendyne drive 522452AU firmware ver 1.35 with a updater i found at one site . Now i find that asus has firmware version 1.50 out on their website for ASUS 5224A. But this firmware checks for asus drive and refuses to update my drive. I tried MKTFLASH ver. 1.80 but it could not detect my drive or my drive’s rom chip . Please help me find flashing software which can install bin files from asus so i can update it to latest firmware ver 1.50 .
The chips in this drive i found out are
Mediatek MT1518E 0249-ARB HF5FW
MEDIATEK MT1516E 0250-CPS 31064
G-LINK GLT5160L16-7TC 249 AB03806
ROHM BD7902FS 248 H47C
Firmware eeprom chip Winbond W29C040P-70B 224082601 248WDSB .
This chip had a sticker saying CRW5224U V: 1.20 C2 8216
Please reply if anyone knows how to flash this into asus firmware . MKTFLASH and winflash dont work correctly.


#10

i came to know i could flash Cendyne drive 522452AU/ ASUS 5224A using ASUSFhB6T4.exe(windows) or flashafs.exe (dos) using file A52V110p.afs . But i could not find A52V110p.afs anywhere . it is not present at asus download sites either . if anyone has this file pls send it to me asap or post it here .