Firmware upgrade for SRD3900?

vbimport

#1

I recently bought a Sylvania SRD3900 dvd/vcr combo at Amazon. Seems it will not play dual layer disks. I called Sylvania support, they said I need a firmware upgrade, but since this model was mfd for Sears, that is who I need to contact. I’ve emailed them, but they don’t reply. Does anyone know where I can get this firmware upgrade? Newbie question: Is this really the cause of my problem? Is a firmware upgrade what I need?

Many thanks for any help with this.


#2

What DL discs have you tried with??


#3

Firmware upgrades aren’t very common for standalone players… Setting the booktype for your writer for +R DL to -ROM would probably be the first thing to try, if you haven’t already.


#4

bufo0892,

what DL medi ahave you tried with?
If not, from where do you have the info that DL wouldn’t work with your device??


#5

According to manual this combo is able to play DVD video discs. (ofcourse also DL DVD-ROM).

Please contact Funai Customer Support at 800-968-3429 for further assistance.


#6

Thanks to all who replied. The disks I’ve tried are just popular movie DVDs that my son checks out of the library. Many movies work fine; every time I’ve had a movie fail to play properly, it turns out to be a DL disk.

I did contact Funai support, but they are the ones who referred me to Sears, saying that I need an upgrade, but that they can’t help because this player is a model produced for Sears. Sears support hasn’t replied to my emails, so I’ll try calling their local repair center & see if I get anywhere.

Thanks again chef, pinto2 & tehGrue.


#7

Not much info here, only similar drives:

http://www.videohelp.com/dvdplayers.php?DVDnameid=2418&Search=Search&#comments

http://www.videohelp.com/dvdplayers.php?DVDnameid=4466&Search=Search&#comments


#8

If it’s failing on pressed discs, it’s probably time for a new DVD player.


#9

My apologies for not getting back to this site for awhile. I’m not sure why the problem seems to have resolved itself, but it has. My son checked a bunch of dual layer movies out of the library a few weeks after my last post. Some worked, a few did not. We played the ones that worked, then later in the week went back & tried the others again. They worked, and we haven’t had a problem since.

Once again, I appreciate the replies from everyone here. Thanks.