Firmware update

vbimport

#1

i tried to upgrade my ltr-32123s to firmware XS0Z, but when i try to install it, an error occurs:

‘‘ERROR:
Can’t found LTR-32123S firmware: XS01-XS0Z drive !
This flash utility only supports LTR-32123S firmware: XS01-XS0Z
Can’t find ATAPI Drive !’’

i have tried flashing my drive with no aspi installed and also with versions 4.6, 4.71 and 4.71.2

cannot flash drive with any version of firmware

clonyxxl also crashes when it tries to start, possibly because of a similar problem with the aspi drivers

PLEASE HELP!


#2

What firmware is currently on your drive? My guess is that your drive’s firmware does not fall within the range XS01-XS0Z. Do you have an OEM drive?

You can use FlashFix to remove that check so that the program will flash your drive. http://digi.rpc1.org/flashfix.htm


#3

the current version of my drive’s firmware is XS0X after flashing from XS0U previously and my drive is not oem (came with box, manuals, etc.)
have downloaded and tried using flashfix 0.99.9.1 and having dragged the flash file into flashfix window, it created a backup and said that it “couldn’t find bytes to patch”

is there a certain location the files should be in when trying to flash?
is there another method of flashing that i could try?


#4

Maybe it’s based on the newer flasher. Does xFlashFix work any better? It’s available in the same place as FlashFix.


#5

problem solved!:bigsmile:

it was due to a problem with my aspi drivers.

but using ForceASPI 1.7 i managed to solve the problem, by removing the current version (4.71.2) and installing the ForceASPI recommended version 4.6 (1021).

i could now flash my drive.

i now also understand how FlashFix works:
when you run FlashFix it will patch the flash file that will then enable you to flash ANY drive on your computer (lite-on or not!) with any flasher (old or new, for your drive or not - enabling you to overclock your drive) but FlashFix does not actually flash the drive!

xFlashFix is for later version drives only (see website for which ones) so i haven’t tried this version for my older drive.