Firmware update problems on Sony CRX-140E

I have a CRX-140E with firmware revision 1.0n on it. When I try updating to version 1.0p, the flashing program says it’s incompatible with the computer when it tries to run (in pure DOS mode of course).

I’ve also tried the Windows-based flasher for firmware version 1.0s. Unfortunately, when I run that version, it says it can’t detect any compatible drives for flashing.

It’s currently the Secondary slave and the OS is WinXP. Any help you people could provide would be greatly appreciated.

P.S. Does anybody have a BIN rip of the 1.0s firmware?

Hi, me again…
I can help you with 1.0p if you want.
The reason it refuses is because the upgrader is coded to accept only Vio computers. Here’s how to overcome that:

Get both (dos)1.0n and 1.0p from here:
http://forum.firmware-flash.com/dl_firmware.php?category=6&manufactor=30

Unzip them, get the “Update.bin” from the 1.0p replace the one from 1.0n with it. Then just run the 1.0n utility.

That’s how I did it and helped quite a few to do the same.
Good luck.

I’m wondering if the Windows flasher doesn’t like the drive being the secondary slave. I’ve tried running the flasher in varoius compatibility modes (Win98/ME & Win2K) to no avail.

I’m going to try putting that drive in a different computer and see how that goes.

Quick update:
I tried flashing the drive with the 1.0p firmware using updcrx21 (the program included with the 1.0n firmware). When booting into DOS and trying to run it, it gave me the following messages:

Check sum data not good. Continue?

After continuing, it gave me the following message while trying to flash:

error(write buffer Mode 7)

Obviously, at this point, the flash failed. The drive came out unscathed though :slight_smile:

Also, the exact error message from the Windows-based flasher is:

No updatable drives present

This time I tried running it with the drive as the Primary Master on a different computer.

Anybody have a clue what’s going on here?

I’ll be happy to send you the bin and flasher combination that worked fine for my drive.

need your email for that.

Ok - 2 files sent.

Just to inform you that I’ve sent the same 2 files I’ve sent you to someone else yesterday, and he updated without a hitch.

I also have the 1.0s update.bin now, but I haven’t checked this one personally.

I haven’t had a chance to test these files out yet, unfortunately. My hope is that if I can get it updated to 1.0p, the Windows flasher will let me go from there.

Hmm…I wonder if there’s a way to patch the Sony flasher like there is a Liteon flasher to disable the drive check :bigsmile:

Could you please send me the 1.0s update bin just in case?

Thanks!

If anybody needs firmware 1.0s for the CRX-140E, you can download it from CRX-140E firmware 1.0s bin for flasher Updcrx21.exe

The real .bin without encription.

Thanks :slight_smile:

Mango (aka Digi) hooked me up with a 1.0s bin file already, but I haven’t yet had a chance to try it (I will tomorrow, honest!).

I’m downloading yours as well, just in case. Thanks! :slight_smile:

Manga’s stuff worked. Thanks a bunch :slight_smile:

Hey Mango, wanna send me the file? I’m having the same problem with the Windows based flasher. The above link doesn’t work anymore.

:bow:
Please Help.

After I update the firmware to 1.0s, whatever burning software I use I can’t burn.
If I use Nero it says ‘SCSI Target error’.
I tried with Alchol, it was different error message but it failed also.

So, I flashed back to 1.0n but the problem still exist.
Help!.

FYI.
Windows 2k pro.