Firmware update problems on a Lite-On EZ-DUB

vbimport

#1

Hello all, i’m new to the forum and will be begging for help shortly! :confused:

I have a Lite-On EZ-DUB external DVD-Writer (as should be evident from the topic :bigsmile: ) and am having problems flashing it with a new firmware. The actual drive model as reported by Nero Info-tool (and Device Manager) is a SOHW-1673SU. The firmware version is XS02 dated 2005-10-17.

I went to Lite-On’s official website and checked to see if their was a newer firmeware for my drive. It showed 3 models of the 1673, the S model, the SU model, and the SX model. Well, i clicked on the SU model and checked the firmware download. It showed a newer one dated 2006-03-22. I downloaded it and it gave me the file EZ16JSOD. When i extract the archive and run the flasher, it gives me an error message saying that it is for the SOHW-1673S drive only! (It does list my drive though so i know it recognizes it)

Correct me if i’m wrong, but isn’t the burner actually a 1673S anyway? Just mounted in an external enclosure? I was under the impression that was how all external burners came.

This is also confusing as the archive name has EZ at the beginning, leading me to believe it’s the correct firmware, although from my digging through this forum and on the net i thought the JSOD firmware was for the S model anyway.

This saddens me :sad: as i was hoping to be able to try crossflashing it to a 1693S after i tried out the official update.

Anyone out there have any ideas? Sorry for dropping in and posting a question without any contribution to the forum, but i couldn’t find any information digging through the net. I thought you guys might have a clue. Since you are cdfreaks and all! :smiley:

Thanks for any help.


#2

Welcome to cdfreaks. :slight_smile:

Don’t know why your drive identifies itself as SOHW-1673SU, because it should be a SHW-163[B]5[/B]SU, according to linked review.
Please recheck and make sure you have the correct drive in enclosure.

More detailed information about your drive and location of purchase would help.


#3

I think jacksonkid probably does have a SOHW-1673SU…



#4

I think jacksonkid probably does have a SOHW-1673SU…

Thanks for clearing that up pchilson. :slight_smile:


#5

@pchilson.
I knew there was something wrong with that picture of yours, but didn’t have the time to check it out more closely before.
Original print on box say “… 8x +DL, 4x -DL”… :rolleyes:
While SOHW-1673 only supports 4x +DL.

[I]jacksonkid,[/I] check your aspi layer. Before flashing to other firmware you maybe also like to backup your eeprom with eeprom utility.
BTW, it seems like all JS0D “1673” firmwares are the same.

Hope more knowledged Litey guys will pop in soon. :wink:


#6

firmwares really are all the same. there’s no difference between internal and external drives.
@jacksonkid
you can download a patched 1693s KS0B firmware here: http://codeguys.rpc1.org/firmwares.html#SOHW-1693S
you can anytime return back to a 1673s firmware.


#7

pinto2, that poster came to me straight from Lite-On and is unretouched. If it is in error then it is error from Lite-On marketing.


#8

Here’s some more detailed info on my drive:

Info from official site.

The specs from their site and the specs on the box don’t match though.

The site says it only burns at 4x DVD+R DL while the box says 8X DVD+R DL. The site also mentions nothing about being able to burn DVD-R DL, but the box says it can burn -R DL at 4x.

The review you linked to here. And this one here both show it to be a SHW-1635S as well. I’m wondering if maybe they didn’t switch out drives to a different model and just kept the same EZ-Dub name.

Those articles got me interested, i stopped mid reply to crack open the enclosure. The internal drive is in fact a SHW-1635S! Even though the label on the underside of the enclosure AND the label on the box say it’s a SHOW-1673SU. Nero and my Device Manager say the same… 1673SU. I’m assuming the was intentional on their part. Though i don’t know why it would be recognized in windows as a 1673 when it’s a 1635.

I just tried the 1635 firmware as well, with the same error message. Telling me it’s the wrong firmware for the drive.

So i’ve got the specs on the box and the specs on the drive telling me two different things. Hmmm…

If it helps anyone the manufacture date is November 2005. At least that’s one thing between the box and the drive that match!

If you need any more detailed information let me know. I was going to type everything out, but i got sidetracked cracking that thing open. The 1635 is a newer generation drive than the 1673, right? I just don’t get why it’s set up like this.

Anyone have any ideas? If there is any information at all on the drive that you need let me know. Thanks guys!


#9

Wooow, this is interesting. :rolleyes:
I think you better get in contact with Lite-On in your country and ask them what they think about this and maybe also request a relacement.

:doh:


#10

I have the same issue, but I haven’t cracked the enclosure open yet. I was searching for a firmware to auto-bitset and I have run into the problem mentioned here. I tried the • KC4B - patched - improved +/-R burn quality (for 1673S, 1693S, Sony 800A, etc.) and no go…Nero reports it is a SOHW-1673(SU). I’ll check back here in a bit. Have to go find the box!

Dr. C


#11

Don’t request a replacement – you might end up going backward. If it’s a 1635S just flash to the latest testing firmware – http://upload.cdfreaks.com/liteon/testfirmware/YV6JWIN.EXE (use FlashFix if it won’t let you with the original flasher, since you’ve opened the case and [I]know[/I] it’s a 1635S) and enjoy the benefits. Confusing, yes, but not the end of the world. You might want to call them and tell them to stop mislabling the drives though.


#12

thanks…this looks good & I was able to upgrade. Now the 135 Booktype works & I set DVD-ROM to the EEPROM…I’m assuming that means I don’t need to manually set the booktype anymore… right? thanks again!

Dr. C


#13

I just bought an EZ-DUB sohw-1673su drive tonight and cracked open the case and sure enough its a shw-1635s with fw XS02. So exactly which crossflash can I apply to this drive? On a side note, I currently own a seperate shw-1635s drive. Can I crossflash this drive too?


#14

@CHRISTOFFS
you can flash it with the latest liteon firmware available. either YS0Y or the test firmware YV6N. YS0Y needs to be flashfixed before applying it.


#15

YV6N applied successfully and allowed Book Typing setting as I stated, but now I am seeing REALLY slow (3x) secure read speeds in EAC & J. River Media Center. Anyone else? I may try the YSOY firmware soon.

DC


#16

Okay now I’m seeing faster burns but spin downs in between each track rip. 9-10x rip in secure mode but then a stop in between is an auible click in the drive. wtf? Any idea what this is all about? I’d like to try the other firmware availabel, is it kosher to flash from YV6N to the YSOY?

Dc


#17

Can anyone advise me on what to do with this drive? I flashed from YV6J>YV6N and no I don’t see spin-downs but I simply can’t achieve anything greater than 3x secure rip in EAC or J. River MC…this is ridiculous.


#18

You can flash back to YS0Y if you want. LiteONs don’t really “care” if you’re going backwards in versions. Go ahead. You’ll need to use FlashFix on YS0Y before flashing it though, as chok0 said.