Firmware update killed my HP dvd300i, is there anything I can do?

vbimport

#1

This is what I get for following instructions.

I got some new DVD+Rs tonight, and on the package it recommended updating my firmware to be sure everything’s kosher. Good idea I thought, I’ve never updated it, and maybe there’ll be some important fixes.

So, I install the software that came with my drive, and it goes through the whole update process. It says everything is fine; reboot the computer for the changes to take effect.

I’m sure everyone can guess what happened next…

I rebooted, and BLAMO! It’s gone.

Windows no longer recognizes my drive. I tried manually installing the new firmware, but since windows doesn’t think the drive is there, it obviously didn’t work.

I don’t know if this means anything or not, but I still see the drive listed in post, and I can open and close it anytime before the starting windows screen appears.

Is there anything I can do, or is it toast?

Thanks for any input.


#2

Try a boot floppy with CDROM support - it may be a Windows issue rather than a drive issue, and you don’t want to be force-flashing firmware, if it’s not the drive that’s the problem.

If it’s a DVDWriter 300 (get someone else to verify , as I can’t positively match that to a 300i), then Etna http://etna.rpc1.org/nec/index.html or Herrie may have a DOS-flasher that can update or downgrade the firmware


#3

it could be a 300c or a 300n. I’ll agree with Matth; the drive is fine, but Windows has a problem. You shouldn’t mess around with firmware in an effort to solve the problem that you’re currently having as you could mess it up worse. Try uninstalling everything that you see under IDE ATA/ATAPI controller in Device Manager, then restart your computer.


#4

Ok, I think I’m getting somewhere now.

I have an nforce2 motherboard, and when I uninstalled the nforce drivers, and removed the IDE ATA/ATAPI controller, the drive reappeared. However, if I reinstall the nforce drivers, it vanishes again. I uninstalled them again, so I can currently see the drive.

I went to the hp website and retraced my steps form last night, and I think I see the problem. I trusted the hp firmware updater to know what it was doing, but apparently it did not. I just checked the firmware version I am currently running, and it’s EK24, which is for the dvd300c, not 300i. In fact, I don’t see any update on their site specifically for the 300i. So, it appears it downloaded and installed the wrong firmware, and trusting it knew what it was doing, I let it go (I rookie mistake I surely won’t make again).

So, it seems to me like I need to revert to the original firmware, since I never had any problems with it. Is that possible? Or what’s the name of that utility so I can find out who actually manufactured the drive? Maybe they have an update that will work?

Thanks a lot for the help guys, I really appreciate it. :slight_smile:


#5

“300i” is a bullshit name. You buy a drive labelled as 300i, but it will show up as either 300c or 300n


#6

I see it now hehe. It’s a 300c. So since that is the case, what’s the problem? Or better yet, is there anything I can do?


#7

Anyone?


#8

Nforce2 IDE drivers have a dismal compatibility reputation.

http://envynews.com/index.php?ID=626#start - Morpheousware remix, note the warning on the “burn trouble” mix, may e better to just use the Microsoft driver for IDE.

http://www.mwarhead.com/news.php - Mwarhead is probably the better known Nforce2 remixer

The issues with Nforce2 IDE, mean that I’ve crossed all Nforce2 motherboards off my possible upgrade list, giving away a few percent performance, but a huge amount of hassle.


#9

Matth, thanks for the links. :slight_smile:

I tried the remixed drivers, and the drive reappeared, but it would only burn at 1.4x. Since it was still under warranty, I was able to get a new one from HP, but now it’s doing the same thing. It should burn at 4x, but it’s only doing 1.3-1.4x. I tried removing it from device manager, and reinstalling my burning apps, but neither helped. Any ideas?


#10

http://www.nvidia.com/object/nforce_udp_winxp_5.10 - try the new release of Nvidia, if the remix isn’t working.

The general answer seems to be to use the Microsoft drivers, but not quite sure how you switch them over, and to ensure that DMA is enabled (standard Winxp driver, it’s in the controller settings, DMA if available)


#11

The drive was ok.
Uninstall the IDE driver using Devicemanager, reboot, install the m$ ones using your OS disk.