Firmware Update Accident

vbimport

#1

I feel like such a n00b right now. I have a Sony DW-D22A that was acting up on another computer, so I popped it into mine and tried to update the firmware to BYS3. Well, I accidentally specified the wrong device on the IDE chain, and it wrote the update to my CD-RW drive. (BTC Model# BCE4012IM).

When I put either the Sony or the BTC drive on the secondary IDE chain, the computer turns on and locks up. (Doesn’t even allow me to enter BIOS). I have an older HP CD drive in, which allowed me to start my computer, but this is only temporary since it does 32x Read/8x Write (suicide :()

Does anyone know how I could fix this problem and make either the Sony or the BTC drive work (preferrably the Sony). I’d appreciate the help.

-matt

Edit: the BTC drive doesn’t even eject when I press the button, and I’ve checked to ensure the power cable is properly connected.


#2

The BTC is probably DOA. :sad:
The LiteOn should not have been affected, but it can alsways be recovered in DOS with MTKFlash. Consult the firmware and LiteOn forums on how to do this.


#3

If the BTC can be hit by that flash program, perhaps it can be recovered by MTKFLASH - though if it jams the startup, it would have to be the rsiky hot-plugging method.

If the Sony has not been misflashed, is it a master/slave issue? - any other drive on that cable?


#4

I was able to pickup an LG DVD burner for free (after rebates) which solved the problem altogether. I’ll stick the Sony/BTC in an older computer and see if i can recover it with MTKFLASH.


#5

It is normal that you comp. gets stuck with the misflashed drive on the IDE channel.
The comp. recognizes a drive on the IDE chain an tries to detect this,
but with the dead drive it is not possible.
The system in general will continue to boot after a timeout on the IDE channel.
So you have to wait in most cases it will continue, after this you can try
everything in DOS or in Windows to rescue the drive.

Good luck

hallo51