Firmware OPTIARC AD 7560A

vbimport

#1

Background: I have this DVD in a Sony Vaio VGN-NR21Z notebook. The lates OEM firmware that it have now is DH12.

Problem: I updated the firmware from Sony DS04 to OEM DH12. I tried to update to any released Sony DSxx version (DS03, DS04, DS05, DS06) but won’t install. Stays at DH12 and I can to update to other OEM versions DX14 and back to DH12 too. But it doesn’t work well in my laptop.

My questions: How can I solve this problem and update the firmware to the Sony DS version?

Sony support said that I’d have to send it for repair, but I’m looking for another way because I’m IT technician and only I need the file.bin to update it.

If someone have any solution I will be so grateful.

Thanks so much


#2

I think you should look here http://club.myce.com/f86/

Ok you already did.

So this could be deleted!


#3

The Sony AD-7560A drive is NOT supported here, and I have looked elsewhere, to no avail. If the Sony file wont load, it seems very likely that I must now buy a new DVD drive for a 4 year old laptop. Nice. Also, your brush-off (dismissal) of the problem is [I]underwhelming[/I]. I think [B]Amazon[/B] could be more informative.


#4

[QUOTE=kendog;2660989]The Sony AD-7560A drive is NOT supported here, and I have looked elsewhere, to no avail. If the Sony file wont load, it seems very likely that I must now buy a new DVD drive for a 4 year old laptop. Nice. Also, your brush-off (dismissal) of the problem is [I]underwhelming[/I]. I think [B]Amazon[/B] could be more informative.[/QUOTE]

Much time has passed since this question was asked. New members here in that time. At least one I can think of that might be able to help with this.

But joining a forum just to slam that forum and a member’s post from nearly three years ago is not going to help you. Please try a different approach at other forums if you are actually looking for help? Ask first, then kick dirt in their faces if they don’t give you what you want?


#5

Yes, I was looking for help and apparently did not ask through proper channels. I only used the forum “search”. And no, I did not join “just to slam”. If there is more current and helpful info on the subject of AD7860A firmware update issues, I would be grateful if you could point it out.[B] Sincere Humility/Apologies[/B].


#6

If you spell out your problem, as many details as possible, we can try to help.


#7

Good day-
Recently, my Win7 Ultimate Sony VGN-NR240E would not read a DVD loaded into it’s Optiarc AD7560A, with no known issues prior. I checked diferent media, “removed” drive and reinstalled drivers in Device Manager, and deleted Registry low filters. I ran all applicable Microsolft Fixits. When I tried to update Firmware to DS06 from DH12, the flash failed repeatedly using Admin rights. After that, I searched again for similar problems, and noted several similar complaints, but no solutions. I ask your members with intimate knowlege of such for explicit help.


#8

Your apology for coming at this a bit heavy-handed is very much appreciated. I do understand what it is like to be frustrated :wink:

Is the drive recognized in the bios or POST screen? Have you tried setting the bios to boot first from the dvd drive and tried to boot from a bootable disc? This would help to determine if this is drive hardware failure or an OS issue.


#9

[Off topic] This thread should have been moved to Optiarc/NEC section long time ago. Sony netbook per se has nothing to do with it. [//off topic]

We have two Sony VGN-Z21 laptops in my family, one with Sony AD-7xxx burner and with the very same problem; can’t be flashed with stock Optiarc firmwares… :flower:

I’m sure more help will come in propper forum section. :wink:


#10

To paraphrase: “Don’t’ Be Here”, “help is somewhere else”. FYI [I]Sony[/I] offers the firmware updates referred to. You get empathy points, tho’.


#11

Part of the problem with trying to “fix” these drives appears to be that they are actually a cheap QSI drive with an Optiarc label.

As it is an Optiarc drive, Pinto2’s suggestion may have merit.


#12

Have you tested it’s ability to recognize a disc at boot-up? You would not want to invest too much time in this if it is a simple drive failure.


#13

Any port in a storm. I think I shall pour some.
Cheers,
Ken


#14

[QUOTE=kendog;2661219]FYI [I]Sony[/I] offers the firmware updates referred to.[/QUOTE]

Actually Sony only offers the DSxx firmwares. The DH12 is offered by HP, the D803 by Lenovo and the DX14 by Gateway.

If a drive suddenly stops working, that has absolutely nothing to do with its firmware. It is either a computer software problem or a drive hardware problem, not a firmware problem.

Based on what you’ve done already I would guess it is not a computer software problem, which leaves us with a likely hardware problem.

Either the lens got dirty over time or the laser degraded/died. Try cleaning the lens. If that doesn’t work, then your drive is dead, so you’ll have to buy a replacement drive … and choose wisely … the last thing you want is to get another poor quality QSI clone, a Teac or heavens forbid, a Matshita/Panasonic …

Choose a newer IDE drive which has good firmware support and one which is well supported by third party tools on this forum. You can find plenty of cheap alternatives on eBay, if you don’t want to pay over the odds for a ‘retail’ replacement.


#15

>>CVS<< Cool this is. Very juicy info you have conveyed. And, I agree. A DVD drive is too cheap to pour this effort into. (sips wine).


#16

[I]cvs[/I], I wish it would be that simple… :flower:

(Off topic)
I’m know you remember your first Sony PS1 that had to be hacked with a new soldered cmos… :bigsmile:

Modern Sony laptops/netbooks are just the same. I’ve had a hard time to get past Sonys TPM protection even when I installed a new Optiarc BD burner in my wifes VGN-Z11 lappy (although replacing to the P9500 cpu [-Z21] was a no problem while it was supported in cmos). :rolleyes:

You can’t even replace a non Sony branded battery withouth a cmos crack.
Welcome to modern Sony World [I]cvs[/I]. :a (//off topic)

[Think we’ll have to start a new Sony “hacks” thread. But then, I’m sure we’ll be banned the very same day. :cop:]


#17

I finished my wine and have swapped the Optiarc with a known good HL-DT-ST GCC4244. Works fine. This leaves one question both answered and [I]not[/I]: Can any BD work in this environment? (corking sound).


#18

Be easy on wine… :bigsmile:

Check your specifications. As long there is an sata interface, all blu ray burners should be supported (except the NEC/Optiarcs, as far as I can se in my VGN-Z11/ Z21 cmoc/ drivers). Only Sony knows why not their own brand is’t supported! :confused:
[BTW, with adwanced bios settings even NECs can be supported…]

In ide only Ma’shit. Google for others and test it out.:smiley:


#19

If you’re only after a BD reader, not a BD writer, then you’ve got a slightly wider choice of IDE drives, including the Sony Optiarc BC-5500A (it would be important to choose the right OEM flavour though, as these cannot be crossflashed to other OEM firmwares and some OEM ones had virtually no firmware updates at all).

Reading BD DATA discs shouldn’t be a problem. For watching Blu-ray discs (BD VIDEO) it all depends if your computer has the hardware muscle to decode HD video in real time. You can run Cyberlink’s BD & 3D Advisor tool and that will tell you if your hardware is good enough for that.

In terms of BD Burners, since the IDE Matshita ones are quite old and not very good in terms of burn quality or supporting most newish BluRay media, I don’t think its worth even considering this option. It would be just a waste of money and BD-R media.

An external BD burner (either a slim one of a desktop sized one) would be a better alternative, but then you’ll have some USB2.0 speed limitations if you want to burn at higher speeds, given the likely lack of an e-SATA or USB3.0 port on an older computer (although it might be possible to add such capability via a PCMCIA adapter card if your computer allows it).


#20

[QUOTE=kendog;2661229] Cool this is. Very juicy info you have conveyed. [/QUOTE]
Indeed it is.

Thank you, CVS and Pinto2. :flower:

I was quite sure that our resident geniuses could add to the body of information on this problem.

I’m grateful for your help. And I think its safe to say that we’ve surpassed Amazon as THE source for useful information on this issue ;).