Firmware issue?

We have a gateway 500gr with a nec 2510a dvd burner. Picked up a large stack of memorex 16x dvd-r discs, but am unable to write to them (have tried about a dozen times, using both ICopyDVD and Nero 6) I am able to burn to an OfficeMax DVD-r 8x disc with no issues. Hate to waste the 200 Memorex DVD’s.

Friend told me it was probably my firmware…flashed in 2.18, and made sure I updated the drivers as well. Even went as far as reblasting the machine and reloading everything. (Based upon a thread I saw)

Discs work fine in wife’s work machine.

Is this a firmware issue or something else? I am at the latest version. I ran free version of dvd info and it shows the DVD-R and drive as NEC 2510A with 2.18 firmware. When disks are in, shows it as a DVD-R, but just unable to write to the Memorex.

Really thinking of replacing my CD Rom with a new DVD burner if thought that would allow me to use the discs, as it may be just as cheap. Any help before doing that would be greatly appreciated.

Memorex media is cheap and not reliable.

Even better than other nonames as you had to experience…