Firmware for Optiarc Ad-7560A ATA Device?

Does anyone know where I can get the firmware for Optiarc Ad-7560A ATA Device?
I did an update and my DVD RW won’t read cd’s or dvds anymore.
I have looked everywhere for it! please help!

You updated with what?

I can’t pin point exactly when it stopped working.
I believe it was after I did some updates to Vista.

I tried the newest firmware I could find to DX14 when I hit the installer it had DX08 at the top so I “assume” this is what I originally had. But, didnt have any effect. same result.

I also tried going to the regedit trick and deleting upper & lower filters.
http://support.microsoft.com/?scid=k…y=13#nextsteps

Problem is when I get there I dont see upper/lower filters listed.
All I see at the address is (5) folders in left pane marked:
0000
0001
0002
0003
Properties

under folder 0000 in right pane it says:
Default
DriverDate
DriverDateData
DriverDesc
DriverVersion
InfPath
InfSection
MatchingDeviceID
ProviderName

under folder 0001 - 0003 in right pane it says: same as above

under folder marked properties, i click it but a windows box pops up and says “Error opening Key” at top of pop up box and then in body:
“Properties cannot be opened. An error is preventing this key from being opened. Details: Access is denied.”

No “upper” or “lower” key tag in right pane anywhere under that address listed in the microsoft help link.

I am using Vista and am in admin mode so dont understand!

Computer Specs:
Vista - Home Premium
Service Pack 1
AMD Turion 64 X2 Mobile Technology TL-62 2.10 GHZ
32 bit operating system

So I am still at a loss!?!
Maybe if I re-install original firmware it could work again?

Also, my driver shows up as
Driver Provided: Microsoft
Driver Date: 6/21/2006
Driver Version: 6.0.6001.18000

I tried to find a newer one but it always says “best driver is already being used”

Driver is unimportant, its just the standard one by m$.