Firmware eraser?

Was hoping someone could help answer this…

I recently upgraded the firmware in my Memorex DVD16+/-DL4RWID2 from JWS4 to JWS6. Mainly because it didn’t recognize some new media. After doing so, no more burning for me. Memorex says that the firmware cannot be rolled back. I was hoping someone might have an idea of how to fix this. The drive still plays dvd’s fine, haven’t tried burning cd’s. Is there a firmware eraser so I can re-flash with an older firmware, or any hacked firmware out there for this drive? Any replies would be greatly appreciated. Thanx! :sad:

Hi and Welcome!

For some drives, you can kill the firmware. After having done this, the next step is buying a new one, as a “brain washed” drive is dead. Unrecoverable.

Considering your attempt to install a newer firmware did not fail, then there might some Windows issue kick in. Is there any possibility to try the drive in another computer?
Also, check device manager if there are some errors and verify, the drive runs in UDMA mode.

Michael

I have tried the drive in Windows 2k, Windows XP, and now in linux (Ubuntu 7.04). All fail with either an “unhandled error”, or “disc write error”.

Hmmm. This would at least sort out Windows issues.
I suspect, this is a Liteon clone, so it might be crossflashed to Liteon firmware if you don’t care about voiding warranty.

Checking the Liteon forum about that wouldn’t be a bad idea then :wink:

Another idea - provided it is a Liteon rebadge, and you have a copy of the original firmware somewhere - would be patching the older version in order to disable the version check. You need Flashfix, to be obtained on http://digi.rpc1.org/flashfix.htm

Michael

http://club.cdfreaks.com/showthread.php?t=135513

Seems it’s a Memorex rebadge of a 1673S with the usual opportunties for 1693S crossflash (with blinkfix).
http://codeguys.rpc1.org/firmwares.html#cat_dvdrw

Thank you for your help, so much. I’m atleast headed in the right direction. Now I gotta get a windows machine up and running to flash it. :slight_smile: Thanx again!

Let us know how it goes please :slight_smile: