Firmware broke my LTR-40125S!

vbimport

#1

Last week I upgraded the firmware on my Liteon LTR-40125S.
I then tried to burn some svcds with nero at 20x. Two came out with a hollow space unwritten to, in the centre of the discs. They were unreadable. I tried again and made another one. It worked. I thought it was a one off error.

I then burned some more svcds. All at 20x btw, and they all came out unreadable. I spent days pissing about with mpeg codecs, cos I thought they were to blame at first. Then I tried to copy a disc with clonecd. It did the same error, and was also burning at 20x. I tried it again at 10x. Oddly, it only wrote at around 8x, which it’s never done before when telling it to do 10x. This time the discs worked.

I went back to the liteon site to get the old firmware back, but it says that the firmware cannot be downgraded, plus there where no downloads for the older firmware. I know that it’s possible to get older firmware back on it, but the problem is actually finding the previous version. The new version was R40ZS0R. I have no idea what was already on the drive, but I hadn’t previously upgraded it.

Any suggestions? Please? Before I have to buy a new writer?


#2

1: have you tried other CD-R disc brands?
2: Have you tried writing at higher speeds like 40X? May sound stupid but it may actually work better at higher speeds.
3: What media did you use?

The reason for this problem is most likely due to write strategy change (the firmware was probably so old that it had Z-CLV write tech, while the new have P-CAV).

1: get ltnflash from here: http://club.cdfreaks.com/showthread.php?s=&threadid=72831
2: get ZS0A binary firmware here: http://dyzan.myftp.org/network/liteon/files/bios/40125s/ZS0A.exe

ZS0A is pretty old and uses Z-CLV tech, so you may try that one.

Flash the drive with ltnflash using the binary file :wink:


#3

Thx for the advice Freak, but the media type is irrelevant, as I’ve been using Infiniti 24x and DataSafe 52x discs for quite a while.
Also, I won’t accept that upgrading my firmware is meant to make it stop working just because it uses a different write method.
And I want to write at 20x, because I’ve found that any faster and svcds become difficult to read for dvd players, as Nero suggests and is quite right. I still don’t get y the program can’t reliably burn svcds faster, but what ya gonna do?

Also, thanks for providing the first firmware binary, but before I try that, could u explain y the write stategy change could cause it to not like 20x?
And I noticed something else. I said earlier that telling CloneCD to burn at 10x made it burn at 8 instead. Alcohol120% does that aswell, and it doesn’t even let me select 10x, but it sure as hell did before. I am very puzzled.


#4

I think that it would be a good idea to try flashing the firmware. You can back up your current firmware with LtnFlash, and if you don’t like ZS0A, you can always flash back. It’s just a good way to determine what the problem is.


#5

I can’t get Itnflash. The link you provided isn’t allowing me access to the page. A little help please?

Also, can somebody please provide firmware R40ZS0P, as I’ve figured out that it was that version I had before and I’d rather have it back to what worked for me before rather than an older version.

Ta.


#6

You can get ZS0P here.


#7

Thanks, I found some pages with most of the firmware releases on it, I’m gonna go back to whichever one that works.

Still don’t get y the new one breaks my drive tho.


#8

Right, I put the ZS0P firmware on, and my drive works fine again. Didn’t use Ltnflash tho, cos the firmware had the update utility.

Anyhoo, problem solved. But if anyone knows why the latest firmware managed to break my drive, please let me know.


#9

I don’t know why that happened; that’s pretty strange. Maybe the new firmware didn’t flash properly. I’d be interested to hear what would happen if you updated to the latest firmware again, but I’ll understand perfectly if you don’t want to mess with it any more.

Anyhow, I’m glad to hear it’s working again! :slight_smile:


#10

Nah, I flashed it two more times after I realised it was broken, it made no change. If they release a newer version I’ll try that, but for now, it stays how it is.

Thx for the help


#11

You’re welcome. Like I said, I’m glad that everything is working again. :smiley:


#12

Originally posted by OC-Freak

1: get ltnflash from here: http://club.cdfreaks.com/showthread.php?s=&threadid=72831

Hi OC.

That link doesn’t work for me. Is that intentional or ?

// Stefan


#13

That link used to work for me, but it doesn’t work for me anymore, either.


#14

Your drive was certenly not upgraded wrong. I own the same drive, and every time i tried upgrading to R40ZS0R, my disc burned @ 20x speed turned out to be burnt like donuts.
I went back to R40ZS0A, but it doesnt handle “new media” i guess… so I’m going to R40ZS0P too now. Anyone knows when there will be a new firmware out?


#15

Good comment, wrong timing.

Most likely this is the end station. :wink: