Firmware and region setting for Freecom

vbimport

#1

Hi,

This is my first post on the forums, so apologies for mistakes made on my part in advance!

I purchased what is id’d as a Freecom RW20J6 DVD+/- external USB2 burner, back in June this year, and can find no info on this model at all, neither here in the product lists or on the Freecom site!

I would like to check out the firmware, which my DiscInfo 1.7.0beta identifies as version 9F51, dated 2007/09/07. This is with a view to updating, and if possible to change region setting to region 0. If the latter isn’t possible, I apologise for naiveity!

Any help on this would be gratefully appreciated, including finding out if this drive has any other manufacturer or firmware identity…

Regards :confused:


#2

Hi and Welcome!

perhaps this drive is a Liteon clone. To verify, get the Liteon Flash Tool and see if you are able to backup your firmware. If that works, then you should be able to set the drive to RPC1 using either Kprobe or LtnRPC.

Michael


#3

Hi Michael,

Sincere thanks, I followed your instruction, and downloaded the Flash Utility for LiteOn drives, v2.2.4, and it ran smoothly, identifying my flash as EF 1400 OE, so it looks like you were correct in your assumption!

I then downloaded LtnRPC, and it instantly disabled my region coding, and just to make sure, I rechecked with DiscInfo again, and it now shows the following message:

Drive region status: No Lock Detected.

However, for some reason, upon checking with a dvd (We Were Soldiers) which has played through the drive without problems previously, and also via DVDfab been copied (for my own purposes only!) without problem, now it plays ok, but I have no sound! I will keep trying options to attempt to solve it though…

Almost solved, thanks to you! I will keep you posted…

Regards :D:bow::flower:


#4

Hi again,

Problem solved, everything is working ok, and the sound problem was simply down to realplayer not having the sound codec for the movie, as when I tried my other players (nero showtime + WMedia + VLCplayer), everything worked as it should!

Congratulations, and thanks sincerely for your help, and for such a prompt response!

Regards :):clap:


#5

You’re welcome :slight_smile:
:clap:

cheers,
Michael


#6

Hello,

This is my first post and I believe I am posting on the correct thread relating to exactly the same.

I have just purchased exactly the same drive FREECOM RW20J6 fw: 9F51.

Is there a way to find the correct firmware upgrade for this since it is not on the Freecom site?

I believe it is a CLONE of Liteon DX-20A4P (in my opinion - not exactly sure).

I downloaded this firmware 9P59 (looks like same type of firmware name) and it doesn’t recognise this is the correct drive the firmware is for.

I tried downloading FlashFix as I want to use OFFICIAL firmware designed for the drive and it gave an error trying to patch 9P59. It says File size not within specified range.

I want to upgrade my firmware to the latest, but I’m scared of making sure I’m using the CORRECT firmware for my drive and making it not work.

Please can some tell me what is the latest correct firmware and how to flash this to the drive?

Thanks very much,

Lee


#7

http://www.freecom.com/firmware.asp?form1=true&form2=true&serie=1148367&Manufactures=1148367

*F51 seems to be the latest, no newer for your drive.


#8

Hi chef,

Thanks very much for your kind reply and the link.

The reasons why I am uncertain that the firmware shown on Freecom may not be correct for my drive, is that when I click on the correct speed at 20X and say my drive is external, it comes up with a slightly different model number being FREECOM_DVD+/-RW20J9 DOUBLE LAYER. Mine is RW20J6 and so I am unsure if my model is included in the update.

Also, the retailer where I bought this states “This product may be substituted with Liteon External 20x Super Allwrite Drive which is of equal specification.” I have looked at a picture of the Liteon and it looks almost identical to my Freecom apart from the position of the reading/writing light for the drive.

Also earlier in the thread, another user is able to make a backup of firmware with the Flash Utility for LiteOn drives and used LtnRPC to disable region coding. That’s why it looks to me like a rebadged Liteon. Also, the firmware names are very similar for Liteon and the version in my drive.

If anyone has any more advice or experience of this drive in relation to its firmware and upgrading, I would be very grateful to know.

I think it would be a good idea for me to e-mail Freecom and ask them where to download firmware for my drive and latest version and see what they say about this.

Best regards,

Lee


#9

Hi,

Just to update you, as I suspected, when I run the only firmware update available from the Freecom site for a 20X speed DVD +/- RW external drive, it says “No matched drive detected ! This utility is only for FREECOM_DVD+/-RW20J9 drive”.

If anybody knows, how do I update my drive’s firmware, please?

Best regards,

Lee


#10

I have worked out how to do all that I wanted now. Thanks so much to all. You guys are the best!

:flower: :clap: :smiley: :bow: