Firmware 1004 error

Hello from Italy !!!

I try to flash the bios of my 1004, but I’ve recived this error:


This firmware can be used on below drives :
(1) DVDRW IDE1004 .
Check Sum : BCD1
Please wait a minute…
Execute command errorA!! 5/20/ 0
Flashing is incorrect!!


Who can help me ??? the current version of firmware is 0040

Thank and CIAOOOOO

Hi and welcome here.

are u using drvupdate or the btc fw-file?

I had the same problem uprading firmware from 0045 to 0051:

I had to load the 0050 firmware first!

Try it and let me know…

thank for reply, where I can download the 0050 firmware ???

http://tdb.rpc1.org

Hello,

I’ve exactly the same problem as OSSONE.
I’m trying to upgrade my f/w from 0037 (original) to the newest 151 dowloaded from BTC site with the “windows flash”.

I’ve read posts which suggest mtkflash with DOS, but this solution would be very difficult for me as I do not have any diskette device.

My OS is WinXP Pro sp1.
I have the same error with the mode “sans echec”.

Would some of the experts of this forum could suggest me any other solution than the DOS-mode ?

Thanks in advance

Philobedo

Try winflashing intermediate versions first…

That’s what I did, and it worked.
But the problem, as I explained, is that it is VERY difficult for me to boot on a DOS diskette as I have no diskette device, and the only winflash available on BTC site is 051. But the technical support sent me a winflash 050, and the reply was fast after my post on their site.
Congratulations BTC support !!!

philo.