Firefox 6 is available for download now, officially releasing this week

vbimport

#1

Firefox 6 is available for download now, officially releasing this week.

[newsimage]http://static.rankone.nl/images_posts/2011/08/JpEWTn.jpg[/newsimage]It seems like only yesterday that the last iteration of Mozilla's Firefox web browser - 5.0 - was released. In reality, it was around 60 days ago. And on Tuesday, the company will officially release Firefox 6 to the public.


Read the full article here: [http://www.myce.com/news/firefox-6-is-available-for-download-now-officially-releasing-this-week-50148/](http://www.myce.com/news/firefox-6-is-available-for-download-now-officially-releasing-this-week-50148/)


Please note that the reactions from the complete site will be synched below.

#2

Think I will wait until the add-ons have been updated.


#3

[QUOTE=Jeffrey_P;2600154]Think I will wait until the add-ons have been updated.[/QUOTE]
Yeah that is the main thing I despise about a new version of FF.

What is worse is when your favourite addons are no longer being developed so its a case of they will never support the new FF.

you can hack them using Notebook but it just feels like you are waiting for a glitch to occur when you do it.

plus while on the subject the version I am waiting for is FF8. I tried the nightly build with support for X64 systems and jesus was it fast! Fastest loading browser I have tried by far to date so it will be a major release when it does come.


#4

All 5 of my addons were compatible when the latest versions (for both 5 & 6) were released. That’s not really surprising because the last major update was 4.0, 5.0 & 6.0 have just been tweaks and small additions. Nothing that should cause incompatibility. In fact, if the old numbering system was kept (instead of trying to compete with the 13 new versions of Chrome a year) FF6 would actually be around version 4.2 or 4.3.


#5

[QUOTE=ilnot1;2600411]All 5 of my addons were compatible when the latest versions (for both 5 & 6) were released. That’s not really surprising because the last major update was 4.0, 5.0 & 6.0 have just been tweaks and small additions. Nothing that should cause incompatibility. In fact, if the old numbering system was kept (instead of trying to compete with the 13 new versions of Chrome a year) FF6 would actually be around version 4.2 or 4.3.[/QUOTE]

You must be lucky.
AVG safe search and maximum add-block are disabled since I upgraded to FF6 V.6.
Back to Ver. 5.
Jeff


#6

Correction, Maximum Ad-block has not had an update since FF version 4.

I paid them $10.00 for an annual sub. The developer told me the guy who does updates is on hiatus. At least they refunded me the money.

Jeff


#7

[QUOTE=Jeffrey_P;2600438]You must be lucky.
AVG safe search and maximum add-block are disabled since I upgraded to FF6 V.6.
Back to Ver. 5.
Jeff[/QUOTE]

Do you think Max Adblock is better than Ad-Block Plus? As I said ABP seems to always be up to date, its very customizable, and has worked near flawlessly for my use. Plus I never had to pay anyone to update it.


#8

[QUOTE=ilnot1;2600468]Do you think Max Adblock is better than Ad-Block Plus? As I said ABP seems to always be up to date, its very customizable, and has worked near flawlessly for my use. Plus I never had to pay anyone to update it.[/QUOTE]
Ad-block plus is updated on a consistent basis. I used it before Max Adblock. Developers need to keep up the good work. With the uncertainty of updates, Max Adblock lost a customer. I’ll just donate to Ad-block Plus.
Jeff