FAT32 to NTFS without losing data

:confused:Can anyone help me convert external hard drive from NTFS to FAT32 without losing data.I have tryed typeing command prompt but it says this when i try selecting the external external hard drive>>>>

C;\users\me>J:\

'J:\ is not recognized as an intetrnal or operable program or batch file.

Im trying to do this so my xbox 360 can read it.I have a full 500GB external and i dont have anyware to temperarly place the data so i can format it to fat 32.

Help will be greatly appreciated!!:bow:

I’m not fully sure that is the solution, but you can do quick a test :slight_smile:

Boot the computer from a LiveCD distribution of linux (gparted for example is purposely created for this kind of operations).

In this way you should be able to convert NTFS into FAT32, even if the safest way, of course, is to temporarily store all data on another disk and format again the disc.

An alternative is to remove the HDD from the box, install it internally, and runb again the conversion from the command prompt :slight_smile:

I wouldn’t recommend doing this if your data is at all valuable to you without backing up your disk first. This is just my opinion. Some people claim that Partition Magic can do what you want and there are probably other commercial partition managers that make this claim. Use at your own risk!

UPDATE !!

Before to try the gparted solution, try another solution.

Reading again your post, I noticed that you inserted a “[B][/B]” after the drive letter. Maybe this is causing the error.

Try again to enter in the J: drive without the “[B][/B]” character. This should work

Borrow one or more external harddrives from friends or family, copy all your stuff to the borrowed harddrive(s), format your NTFS drive as FAT32, copy everything back.

I was wondering about that backslash myself.I wonder if I should try to refrmet.I read that my Samsung came NTFS but when I started using it I saw it was FAT 32.Freind said it wasn’t a problem (I am just stashing my MP3’s) but that adavtage of NTFS is that it also reads FAT 32 but FAT 32 does not read NTFS.Any other reasons to reformat?Bummer of I have to take 150 Gigs back to orignal single 320 in my XP computer.Other reasons to go NTFS?
Chazz

Come to think of it, you can’t format a partition (drive) larger than 32 GB as FAT32 with the builtin tools in Windows - you’ll need some 3rd party tool like e.g. fat32format, Fat32formatter or similar.

I haven’t used either of those tools myself so this is not a recommendation.

yeah i have tryed it both ways it still comes up with the same error.

[QUOTE=DrageMester;2456882]Come to think of it, you can’t format a partition (drive) larger than 32 GB as FAT32 with the builtin tools in Windows - you’ll need some 3rd party tool like e.g. fat32format, Fat32formatter or similar.

I haven’t used either of those tools myself so this is not a recommendation.[/QUOTE]

Yep DargeMester is right XP or above will not do Fat32 on a large drive like 500GB’s the way I see it you have a few choices

  1. do like Derge said and try those utilities
  2. find someone with an old Win98 startup floppy disc and use the format command (only drawback you will need the drive hooked up to the mobo and a floppy drive)
  3. partition the drive into a couple of smaller 32GB partitions and leave the rest of the other partition as NTFS but you will need something like
    Partition Magic or gparted to do that but you still run the chance of loosing some or all of your data. :eek:

yeah, i dont wanna risk it becuse i have 14GB of family photos and all seasons of shows.so im gunna buy another external and format it to fat.

I appreciate your help everyone, thank

[QUOTE=peter griffin;2457087]yeah, i dont wanna risk it becuse i have 14GB of family photos and all seasons of shows.so im gunna buy another external and format it to fat.

I appreciate your help everyone, thank[/QUOTE]

Hello, the solution is simple, Open start menu type “CMD” right click and “run it as Admin”

Take not of the drive you want to fix ie “J:” than type this
"chkdsk j: /f" Basically that is a command that will run a diskcheck on your drive j with a FIX parameter. It will fix any problem preventing the drive from reading. Also take note of how you write a drive there’s no \ just the letter and a colon. Also make sure you use forward slash before the f.

Once that completes you should type “convert j: /fs:ntfs” you won’t lose any data in this process except a file that is corrupting the drive. If you type it correctly it will ask for the name of the drive. type it how windows explorer sees it. Which is most likely the last one you attempted to put on the drive. But my sujestion is once it fixes the drive befor this step is to copy your files to your computer than use windows disk manager and format it. But that will erase any thing on the disk but a much more reliable process.

I can only assume you want NTFS file system because it can handle larger files, items over 4gb. Which is probably what you tried to place on this drive causing the crash?