Fails to eject unless cd is installed

I currently have a Liteon LH-20a1s, This drive works great with the exception it will not eject a cd unless I leave a blank one in it.

If I have no media in the drive, it will attempt to eject/open the tray but then sticks. If i have a cd ect in the drive it works fine.

I just would like to know if its possible to correct this problem.

Thanks!!!

First off Welcome to the forum drw1710

It seems just about all older and maybe even newer Liteon drives suffer from this flaw
I found this posted somewhere but I can’t remember where it was at the moment and
I haven’t tried it yet myself so it may work and then again it may not work.

[B]In many Liteon drives tray gets stuck and would not eject. The reason for it is too
strong magnetic puck that presses the disc to the spindle. There is a way to fix this.
Tools needed: good quality duct tape, sharp scissors, philips #2.

  1. Remove the drive. 2. Eject the tray with a pin. 3. Remove four screws.
  2. Loosen front bezel. 5. Gently pry out the innards away from the metal
    case to get access to the puck.

The magnetic puck is a small round rare-earth super magnet encased in white plastic.
It has a shape that allows sticking to its bottom a small round padding inside of the
recessed area - the sticker should have no more than about 10 mm diameter and have
a small 2 mm hole in the center. I made the sticker from two layers of duct tape.
Make sure to use good quality of tape, so the glue would hold well but not spread from
underneath and cause more trouble.[/B]

I had good luck fixing the “won’t eject” problem in my SHM-165P6S, a slightly older model, by replacing the rubber belt in the tray mechanism. I could feel that the belt had deteriorated and become harder and less flexible.

The replacement belt I got (it may not be the same for the 20x models - you’ll have to measure yours) was from MCM Electronics, #42-025, with an inner circumference of 2.311" and thickness of 0.040". They have a large selection of belts but unfortunately don’t have a cheap shipping option. (If you’re out of the US you would probably want to look for another source.)

Hi,
I had a similar problem. I’ve had this burner for about 3 plus years, a 2008 SATA plug model. In the past year, it has become more difficult to open tray when the button was pushed, as it sounded like it was struggling like something was jamming it. In the past month, I have had to hold the button down for a few seconds (very firmly) and after three attempts of doing this, it would finally open. This week, even this isn’t working so well. Depressing the button to close the tray hasn’t been working so easily either, and I would have to hold down hard on the button, or gently push the tray partially to get it to grab and close the rest of the way. I even installed a third-party application “close tray” to see if I could use the computer to close it and open it for me, but even this wasn’t working, especially “close tray” selection. Anyway, I thought I would have to buy another burner, but I found this thread.
I tried the suggestion by getit29, and had to reread the instructions several times to understand what was suggested. I removed and opened unit as suggested, and inside top cover case of unit is the magnet inside a white plastic disc. The puck is inside the case from this side, and you are not able to remove it. I checked it with a piece of metal to make sure it was magnetic and the right part. The instructions were wrong in where to put the doubled over layer of Duct tape.
Instead of removing four screws, opening up innards and applying padding to the puck from the inside (I did this, used a lite application of glue to stick it in place , put it back together, and sure enough the unit would open and close easily for the first few attempts, but it also would make a gear ratchet whirring noise when the tray would close, and especially if you put a disc in the drive to play it. It would make a terrible noise and refuse to do anything. So, I took unit back out, and noticed the area where the puck is on the case, that there is a plastic cover on the outer side where the unit’s label is located. I took a sharp pocket knife and removed this cover plate, releasing the glue that was applied around the edges at the factory. Some are made of plastic and some of metal, especially the newer ones are made of plastic, as I was able to get out an older LiteOn IDE cable unit and look it over.
So instead, to get to puck without having to open uinit, look over my pictures to see what I am referring to. Remove the circular cover plate which holds the plastic magnet puck, then with slide cover of magnet towards you, turn it clockwise to remove this hold down cover (it has three tabs, but one in photo has one tab broken off). You’ll see the magnet. Yes, it is strong. Then you can see where I cut out a 10mm circle of doubled over Duct tape and used a nail to put a hole through the middle to fit over the plastic post on the white plastic puck bed. Use the cover that has the twist slots with magnet to push the tape down flat, then push firmly while you twist cover in counter clockwise motion to lock it down. Insert back in unit and place circular cover plate back on case. The old glue was sufficient for my cover to stick back on good.

Now the unit opens and closes fine and plays fine without any weird noises from a poor repair job. Very true that it appears to be just too strong a magnet used, preventing the release of the spindle.

I had this problem too, I replaced the rubber drive belt, and it worked fine, but I had to retire it, as it was scratching my discs!

RCM, thanks! That makes sense because this unit worked fine when I first got it. I assume the belt working against the strong magnetic pull wears out sooner than it should. I will be ordering some from MCM Electronics, but this fix worked for what materials I had on hand.

I have a DH20A4P that is sometime hard to open . The belt is the problem. So far cleaning the belt & plastic pulleys with some isopropal alcohol on a cotton swab has worked. You want to let the alcohol evaporate for about 15 minutes before using the drive.

[I][Sorry, I am not able to edit my post. I finally found information on this that there is a time limit to do so. I also cannot delete my attachments. The mods can remove the images that I posted in my first reply, or show me where I can do this. Anyway, here’s a how-to with the same photos with additional information, but this time they are coming from my photo sharing site.[/I]

I’m repeating myself here, but opening up the unit and putting a sticker - pad on the puck from the inside only messed up my drive further and it would not play a disc but make an additional noise. So I had to take unit out, open it up and remove the pad. Back to square one, but I had a clue as to the magnet being part of the problem on this brand of optical drives.

Here is what I did, with made up descriptive names of the parts in question as I don’t know what they are correctly called:

Remove optical drive from machine. No need to open unit up. Remove cover plate, that can be made of plastic, or on older units, of metal. With top side up, using sharp pocket knife, carefully pry around the cover plate (and label) to loosen the glue that holds it down, working knife in angled circular direction of plate. No need to go all way round, just enough to easily remove the contents: the white plastic puck.

Turn small metal twist cover in clockwise motion to unscrew it from plastic puck, being careful not to break off any of the three plastic tabs, as I had done the first time I unscrewed one (actually, I used a screwdriver to push one of the plastic tabs upright, thinking that was how it was held down, which broke it off). If you pay attention, you can easily see from the small twist cover that you unscrew it. Once lid is removed, you will see the 10mm metal magnet that is held magnetically to the twist cover. It has a hole in the centre. You can check magnetic strength with your screwdiver or pocket knife and find out just how strong LiteOn’s magnet is. This magnet is what pulls the spindle up to secure the disc in place against the plastic puck, and if the magnet is too strong, it can stretch and prematurely wear the rubber belt as it refused to release the spindle. It can also cause the spindle to not fully pull away from puck when button is pressed to open tray or close tray, resulting in the spindle dragging along the inserted disc and scratching it. At least, this is what I believe happens. I’m not an engineer.

Next, double over a piece of Duct tape to make it two layers thick (sticky sides against each other) and measure and cut a 10mm or so circle. Remove the magnet from the small metal twist plate and use magnet as a pattern. Remember to replace and center the magnet back on the twist cover. You can adjust padding/sticker with scissors to make sure it will fit in the inner circle section of puck. Then with nail, poke a hole through the middle, making it large enough to fit over the centre post of puck. (I tried making a three layer circle padding, but it was too thick and wouldn’t allow the magnet and twist cover to close down, so two layers is sufficient.) Use magnet and twist cover to depress the tape flat, then with counter clockwise motion, push thumb and secure the twist cover making sure the three tabs lock in their grooves. No need for glue in this project.

Place puck back on top of unit, and close the cover plate, pushing it down to secure it. If you need glue, then do so, but I didn’t as the old glue was still sufficient to hold the plate in place.

Replace unit back in machine and test it.

Mine has been working as it should for two days now, whether I am in Linux or Windows XP. The button works as well as using “eject” from computer.

I was thinking another option would be to replace the magnet with something less magnetic. We have plenty of pliable magnets on our refrigerator, and wonder if making one to fit would work without the need of a any added diffuser padding.

An update to say that this drive continues to open and close tray easily, as well as plays movies and burns fine.

I went ahead and fixed another Lite-On SHW-160P6S unit that my husband had brought back that was malfunctioning, and it too tests fine.

Note: This is a common flaw with Lite-On models of this period as they use a magnet to grab the spindle and lock it down on disc. I don’t know if they’ve changed their design, but I assume they have. I have an Asus optical drive that does not have this feature. It is the same age and has never given me any tray discharge problems.

I big thanks to getit29 for pointing out the problem as he or she gave me the clue as to how to go about repairing it from another approach.

(and, another request to moderator to remove the attachments in my first post #4 as they are not needed, and I am unable to delete them. Thank you. )

This image shows how I used the magnet as a pattern for the diffuser pad - Duct tape.

Thanks to getit29 for the original fix and to simplately for improving it! My drive now works, too! :bow:

simplately originally had some example pictures that are no longer available, so I took pictures when completing my repair to post here. (Hopefully, ImageShack and PhotoBucket will keep these available longer. :iagree: )

My contribution to this fix: Making a spacer of electrical tape stuck to itself is a little too thick and puts allot of pressure on those little plastic clips (fortunately they have some flex) when the cover is twisted back on. You can make the spacer of any material, such as thin cardboard or a few snips of paper. Just be sure it’s not as thick as the doubled tape so it doesn’t strain the clip(s) to the breaking point.