Extracting Audio from an MP4 File

vbimport

#1

A series of MP4 video files that I download report the following audio specs in GSpot 2.70a:

mp4a: MPEG-4 AAC LC
32000Hz 96 kb/s tot (2/0)

Presently I use AOA Audio Extractor to extract the audio as a wave file. The resulting wave file is about the same size as the video file. Is there a way to extract the audio portion without converting it to a new format, such as wave? That is, the file that is extracted is the AAC file that is exactly the file that is multiplexed in the MP4 file? The file should be exactly the same quality as the original while being smaller than the wave file.

While I know a lot about audio, I’m not current on AAC (what’s LC?) or even MPEG-4. The two objectives of this request are to hopefully demultiplex the audio portion of the file with no recoding.


#2

Use AviDemux. It’s not just for AVI anymore. On the ‘Audio’ dropdown is a ‘Save’ option.


#3

[QUOTE=olyteddy;2116223]Use AviDemux. It’s not just for AVI anymore. On the ‘Audio’ dropdown is a ‘Save’ option.[/QUOTE]
I downloaded it and installed it, but I cannot figure out how to demux the audio file. There is no help file. What to do?


#4

quote olyteddy,

On the ‘Audio’ dropdown is a ‘Save’ option.

This [B][I]should[/I][/B] work, but apparently with version 2.4.3 (r4276) it doesn’t. I also have tried.

neumannu47,

Use Google and download & install RipBot264 then open your mp4v with it.
Just [B]open[/B] the file, don’t run anything. Then look in the audio window and observe the temporary folder created holding the audio data.
Go into that folder and copy the audio file (probably will have .aac extension)
That’s it. :smiley:


#5

neumannu47,

If RipBot264 is too big for your needs,
then try YAMB.

It works well, and has a very straightforward interface.


#6

This should work, but apparently with version 2.4.3 (r4276) it doesn’t. I also have tried.

I did too, just before posting. It worked with MP3 and MP2 audio, so maybe it’s a buc with AAC? Do you have an AAC codec, suchas Nero’s installed?


#7

olyteddy,

Yea, mp3 and mp2 both work–confirm.
Demux of the AAC track from a MP4v seems to have a bug, either that or I am botching it bigtime. :doh:
The file created by Avidemux using the procedure you outlined above appears to be the right size, but no program I have can recognize it as a legitimate audio file(tried VLC, MPC, foobar2000, & Winamp)
I also tried GSpot and MediaInfo, both give zilch info on the created file. I also tried changing the file extension: .aac, .mp4,. m4a—the file just isn’t recognized as audio by the software I have.:frowning:

Extracting the AAC track from the same MP4v using YAMB or RipBot264 are recognized and played by all the above software. (and extraction is fast) :slight_smile:

Sorry if the above is all OT–YAMB & RipBot264 both extract AAC from mp4v without re-encoding if the mp4v contains an aac track. I am sure there is a lot of other software out there that can do this as well. :bigsmile: