External Enclosure PROBLEMS!

I have a ME-320 BYTECC external enclosure, I have put a WD 160 gig HD in this, was working like a champ the first few days, then suddenly it decided it doesn’t want to even fucking reliaze it’s even PLUGGED IN!, this is a USB 2.0/Firewire…so I have tried both, they both don’t work.

The HD spins, the light is on, the fan spins on the external case, yet…windows doesn’t realize it’s plugged in, I even checked the USB power options, it isn’t even sending power to USB

WTF is going on? I am on WinXP and do have Firewire and USB 2.0…and has worked JUST FINE the last few days!!! HELP!

P.S. this is the 2nd time this has happened, SAME problem, I have RMA’d the last one
I have also tried this in 2 friends computers, doesn’t work

http://www.byteccusa.com/product/enclosure/ME-320.htm

CLIFFS

  1. have BYTECC ME-320 External Enclosure
  2. WD 160 HD is in it
  3. Worked fine the last few days, now Windows doesn’t recognize it’s even plugged in
  4. USB/Firewire on it is not working
  5. Light is on, HD spins, Fan spins, windows doesn’t realize it’s there
  6. 2nd time it’s happened SAME problem, 1st was RMA’d to Newegg
  7. Tried on 2 friends computers doesn’t work
  8. Tried swapping HD…doesn’t work
  9. tested HD …HD no problems

First of all , disable ALL power management inside ALL drivers of USB , firewire etcetera. Windows likes to power all things down , which makes them very very unstable.

Then , check in your usb drivers if the device still consume power (there’s a % notifitcation somewhere). If it does , the device IS recognized by windows , but driver corruption may prevent it from working.

Then , remove all usb devices (physical) , then remove all usb device drivers (windows hardware) and reboot your system. Let windows recognize all device drivers and reboot again. Again, check the power consumption.

After that , make sure there are no firewalls and antivirus software running , they tend to capture the reading and writing processes of an operating system. If needed , reboot without having both active and check if it works.

Last : A device NEVER “just fails”. There is always some 3rd party involved. This can be either a piece of software (update , program , driver , trojan , virus or automatic reconfiguration schedule) or a (malfunction of) hardware. Retrace your steps from the point where you are absolutely sure it was still running perfectly. If necessary , go back to another restore point in windows xp.

I’ve got a very similar problem with a BYTECC external enclosure. Sometimes it works great in XP. Other times, the system thinks that the external drive cannot handle long file names. When that occurs, XP sees the format of the drive as RAW instead of NTFS. Any suggestions??

:confused:

I am having the same issue. My friend bought a bytecc enclosure and it worked good for the first day and now won’t find it. he gave it to me to test out. i put a cd rom into the enclosure and it found it right away so i can rule out thats not defective. i put the HD into my computer and it found it right away so its not that. I even reformatted the drive while it was in my computer to try that. still nothing when i put the drive into the enclosure. its like its not even plugged in. won’t even say there is a usb device plugged in until a few minutes later it gives an unknown device error. I bought the same enclosure and a 160gig seagate drive and mine works fine. never had a problem for months. he has an 80 gig seagate. thats the only difference. any help would be much appreciated.

I recently bought the Bytecc ME 320 external enclosure. All the website i’ve seen on the product tested it well and it passed all the benchmarks.

I’m testing it right now. I was wondering if it’s possible to mount or format an HDD on it ?

I assume that using an already formatted HDD is possible or even for a CD or DVD drive !.. but what about the format option !? Has anyone tested it yet ?

Thanks in advance,
Hugo