External Enclosure - BENQ 1620

vbimport

#1

I have the BENQ 1620 and before reading hear I bought the Plumax Ext. Enclosure with Cypress chip. Unfortunately, the drive is unable to be recognized in this enclosure. I have tried flashing the firmware to several different versions including the EW external version. Still no luck.

I would appreciate if someone could post the sucessfull external enclosures they found to work with this drive so that I can choose one to purchase knowing that it will work.

Thanks
Rob


#2

Hi robdls, and welcome to our forum.

Maybe you will find some help in this thread.


#3

Hi,

I used to hav emy benq 1620 working fine on my computer but recently I did a clean install of the XP on it. Now when I went to use my drive in external enclosure today the drive/enclosure is not recognized. It says there is no driver for it although it is supposed to be included in XP. I tried the Prolific site but only hav eit for win 98.

If anyone has it and can link or email it to me please reply I would be so appreciative since I have no access to the driver cd that came with my enclosure.

Any help suggestions are appreciated too!

Thanks
Rob


#4

Threads merged…

You may want to look at this thread:
[thread]119149[/thread]


#5

Need the Prolific 3507 chipset driver for external enclosure as mine is not recognized automatically in XP

Thanks


#6

Their is no XP driver, the operating system itself comes with the driver needed, try checking the device manger for any unknown devices, also depending on the connection if your using it on a USB 2 port, you will need to install WinXP Service Pack 1 or 2 to enable USB2 support (or a third party driver for the USB2 controller if you don’t intend to install the service pack)


#7

There is an XP USB 2.0 driver, for XP without SP1 doesn’t contain it. XP SP1 and up there is no need for specific driver.


#8

[B]Rob,
The Plumax Case comes in two versions:
#1 = Oxford 911 (Firewire) and Cypress (Usb2) ChipSets
#2 = Prolific PL-3507 (Firewire & USB2) on same ChipSet

#2 WORKS !!!
#1 50/50 rate of success !!!

Hope this helps…
[/B]


#9

Hi,

I have #2 and I had it working on my computer before I did a clean install of XP. Now when I connect it it says found new hardware…your new hardware is sucesfully installed and ready to use. Then a few seconds later I get an unknown device error when I look into the unknown device it says no driver installed? any clue?

Like i said it worked before i clean installed my xp


#10

The device manager has an unkown device which I believe to be the ext enclosure and dvd. I have usb 2 with sp1 installed.

Any help is appreciated.


#11

OK - Clean install of Win/SP. Do you have SP2 installed ?

If you have a clean install and SP2 installed - I am betting something went wrong with the flashing of the 3507 case (firmware).


#12

Maybe you have changed the jumper setting of the drive? It has to be Master.


#13

Hey,

Thanks for that bit of info. I had the drive set to Slave. I set it to MASTER as you said and was able to get a bit different response. Know I get This device cannot start. (Code 10) USB MASS STORAGE DEVICE.

Any solutions to this?

I really appreciate the help.

Robert


#14

Hey,

I disconnected the device again and reconnected and now I am back to UNKOWN DEVICE.


#15

Well I got the same error msg from WinXP SP1 with my Coolink enclosure. My other burners and readers work fine in this enclosure, so it is some kind of incompatibility between enclosure and burner. I guess sg similar is happening to you. Are you sure that you have the same IDE2USB chipset in your enclosure as others above?
I recommend ViPower Smart Cables to everyone who wants his burner working outside of the PC case.


#16

Have you tried uninstalling the “unknown device” from the device manager (right click on it & select uninstall) and reboot windows with the drive still connected and let it re-detect the drive to see if that works ?


#17

Have you tried to reboot your PC with this device ON?
Maybe any changes you made in BIOS corresponding USB?


#18

Thanks for all the help. I seem to have it somewhat functional now. Basically when I first power on the system it gives me Unknown device if I disable the device and then power on the ext enclosure again it recognizes it and works? Beats me but I appreciate all of the help everyone supplied.


#19

Just out of curiosity, Did you update the External case PL-3507 Firmware?..This is different than the BenQ firmware.
If you did not, that actually may be the base of your problem. I’ll be glad to walk you through the process if you feel like that would help.


#20

I just realized your problems were with USB, not 1394…not enough sleep…
So I am not sure any PL-3507 firmware upgrades will help in this matter…so don’t get your hopes up. And I am willing to walk you through the process if you need to.
Right now I think I need some sleep.