External Drive Delayed Write Problem

I just installed a Maxtor external 250 gig USB drive. When I try to save bittorrent files to it, it sometimes dismounts. Then a message displays “delayed write failed.” And the bittorrent stops.

Got any hints or tips about how to fix this problem? Any help is much appreciated.

Windows XP SP2, Dell Pentium 3, 3 installed drives, 2 internal.

I’m using Utorrent for downloading, their forum provides no answers. They claim it’s a Windows issue.

check these similar threads they contain good info & suggestions & what worked for them
http://www.softwaretipsandtricks.com/forum/windows-xp/8390-delayed-write-failed-usb-disk.html
http://forums.viaarena.com/messageview.aspx?catid=16&threadid=50469

yeah it can be windows issue, get the KB908673 hotfix from http://hf.xable.net/ , also get the latest chipset driver from dell’s site

some ppl have solved it by

  1. the hotfix^
  2. tweaking some stuff in the registry (more info about that in the threads^)
  3. uninstalling activesync
  4. replacing the usb cable (the usb cable was faulty)
  5. buying a new usb card thats based on a nec chipset (usb controller was the issue,seems more common on motherboards based on via chipsets)

A flakey enclosure chipset can do it too, but it’s usually driver-related. If write-cache is turned on for the drive in device manager, turn it off.