External Buslink (NEC-3500AG) dvd burner will only read and write at 5x

vbimport

#1

Hello everyone,
I have recently purchased a Buslink external dvd burner but it does not perform at its highest speed (16x). I have it connected to my computer through a USB 2.0 pcmcia card (NEC PUC-102) and have installed an enhanced bus driver controller yet the write and read speeds will not go over 5x. Actually, Nero Drive Speed detects only speeds 1x and 5x every time I load the application. It usually takes 21 minutes to copy a full-size DVD to the hard drive and another 20 to copy it on to a blank DVD when it should take around 8 minutes which is te estimate Nero gives me every time I burn a DVD. My hard drive can read and write data at 19Kb per second when tested yet neither the CPU nor the Hard Drive nor the RAM memory perform at their maximum when copying a CD (at least according to “Speed up my PC”). I have now spent countless hours trying to find out why my DVD burner will not work at full speed and the only thing I can think of is my TI-1225 card bus controller is somehow slowing down the data transfer process. Does anyone have any ideas on how to solve this problem? Thanks everyone for their time in advance.
Javier

SYSTEM INFO
Processor
Model : Intel® Pentium® III
Speed : 869MHz
Performance Rating : PR1043 (estimated)
Type : Standard
L2 On-board Cache : 256kB ECC Synchronous, ATC, 8-way set, 32 byte line size

Mainboard
Bus(es) : AGP PCI PCMCIA CardBus USB i2c/SMBus
MP Support : No
MP APIC : No
System BIOS : Phoenix 4.06CJ15
System : MTC Corporation 7521
Mainboard : MTC Corporation 7521
Total Memory : 382MB SDRAM

Chipset 1
Model : Silicon Integrated Systems (SiS) SiS630 CPU to PCI Bridge
Front Side Bus Speed : 1x 134MHz (134MHz data rate)
Total Memory : 384MB SDRAM
Shared Memory : 2MB

Video System
Monitor/Panel : Default Monitor
Adapter : SiS 630/730

Physical Storage Devices
Removable Drive : Floppy disk drive
Hard Disk : HITACHI_DK23CA-20 (19GB)
CD-ROM/DVD : _NEC DVD_RW ND-3500AG USB Device

Logical Storage Devices
1.44MB 3.5" (A:) : N/A
Hard Disk (C:) : 19GB (5.1GB, 27% Free Space) (NTFS)
Adaywithoutamexican (F:) : 7.6GB (UDF)

Peripherals
USB Controller/Hub : NEC PCI to USB Open Host Controller
USB Controller/Hub : NEC PCI to USB Open Host Controller
USB Controller/Hub : NEC PCI to USB Enhanced Host Controller (B1)
USB Controller/Hub : SiS 7001 PCI to USB Open Host Controller
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Root Hub
USB Controller/Hub : USB Mass Storage Device
PCMCIA/CardBus Controller : Texas Instruments PCI-1225 CardBus Controller
PCMCIA/CardBus Controller : Texas Instruments PCI-1225 CardBus Controller
Keyboard : Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Mouse : PS/2 Compatible Mouse

MultiMedia Device(s)
Device : SiS 7018 Audio Driver

Printers and Faxes
Model : Microsoft Office Document Image Writer
Model : HP DeskJet 840C/841C/842C/843C

Power Management
AC Line Status : On-Line
Battery No 1 : 100%

Operating System(s)
Windows System : Microsoft Windows XP/2002 Professional (Win32 x86) 5.01.2600 (Service Pack 2)

Network Services
Adapter : Asante AeroLAN AL5410-G #2


#2

You don’t have a powerful PC. Connect the NEC to the Secondary IDE channel, either slave or master mode. 19 MB/sec isn’t very good. My 600 MHz PIII will do a minimum of 28 MB/sec with a 7200 rpm hard drive. This system can burn up to 12X. The CPU maxed out at 16X, resulting in 8 min burn.

I think you could burn at 8X if you dump the crappy USB 2.0. It’s probably eating 10 to 20% of your CPU clock time.


#3

Thank you for your reply Furballi,
Do you mean then that the USB 2.0 PCMCIA will not perform at 16x or 12x no matter what? Since my PC is a laptop, how would I be able to connect the external burner to one of the IDE channels?
Thank you again,
Javier


#4

Probably not with your ancient PC due to the speed of your CPU. 16X requires a lot of CPU clock time. Time to dump the notebook if you want to get the most out of the new DVD burner.


#5

Thank you again Furballi,
I recently purchased a 1.2Ghz tualatin Pentium III processor just a week ago and I should get it in the mail soon. I know my computer is old and upgrading it will always be, in one sense or another, a waste of money but I really like my old Mitac: for my it is more like an old collectors car or something like that. In any case, most of the upgrades are external (I have also just bought a quicker external HD drive (7200rpm) so I guess I will always be able to plug those on to a new computer.
Thanks again,
Javier


#6

Odds are good that your HD is running at it’s max speed at 5x. Keep in mind that sustained transfers are much more difficult than benchmarks. Also, you have low free space, and probably a fair amount of fragmentation on the drive.
You could try a different PC card for the USB2 connection, but I’ll bet it won’t help.


#7

I also though the problem might be the hard drive. If the dvd burner is supposed to run on a very fast computer to perform at 16x why does Buslink advertise it saying that the required system is a Pentiumm III 700Mhz with a USB 2.0 port?
Thanks,
Javier


#8

Very few, if any, people have ever seen USB2 run at 16x. Most see a limit of 8x or 12x.
Laptop hard drives are notoriously slow, and I’m sure yours is fragmented too. If you want to speed it up, either do a fresh install or get a good 3rd-party defrag utility like Diskeeper 8. My best advice is to limit your burn speed to 4x, it may even be slightly faster than trying to burn at 6x or 8x.


#9

In my case, the HD transfer speed was fine…minimum 29 MB/sec under normal load. At 16X speed, the demand on the CPU was just too much, so once the load hits 100%, the HD slows, and the NEC reduces the write speed to avoid buffer underrun. Still a great burn, but max speed is closer to 14X.

You need to use the most efficient path of data transfer if you want to achieve 16X speed. Connect the NEC to the Secondary IDE channel INSIDE the PC. Make sure you hard drive can deliver a minimum of 25 MB/sec using HDTUNE. And with the new CPU, 16X should be within reach. DO NOT USE USB 2.0!

I’m 99% sure that I can burn at 16X with a 1 GHz processor. Anyone with a Slot 1, 1GHz, EB PIII for around $20?


#10

You can try a store like Starmicro: http://www.starmicro.net/SearchResult.aspx?CategoryID=31&WebID=cf69e374-7044-4c31-9ff8-861708d22874
even though I don’t think you will be able to find anything under 50$.
I am still amazed that USB 2.0 will not reach the speed rates at which they advertise it.


#11

I have another question,
Since my Buslink DVD burner offers the possibility to choose between firewire and USB 2.0, Would a Firewire enabled PCMCIA card be faster than my current PUC-102 USB 2.0 card?
Thanks


#12

Short answer…yes. Firewire has a much higher throughput than USB2 on sustained transfers.


#13

This is just great. I tried to upgrade my 866 to 1.2 and now the computer will not boot at all. Any ideas about what to do? Is there a forum or chatroom I can go to?


#14

Suspect you may have an EB compatibility issue. Are you using a powerleap product?


#15

I actually did not know Tualatin-based processors required a special socket. It is just unbelievable how they make upgrades so difficult… In the end the only thing they want you to do is dump your old computer and buy a new one: it is like modern cars, they just fill them up with electronical devices so nobody can fix anything. I did not use a different socket for the tualatin pentium III and I tried to put back the old coppermine but none of them will work now. The final straw is that my 370 socket is one of the old ones so it does not come with the zero friction leveler. How can I make sure the processor is in the right place? When I removed it it was hard to get it out of there but when I put it back it does not seem to be firmly attached to the socket.