EW162I and Nero CD-DVD Speed

I was wondering if it just the drive or my computer because I can’t seem to ever get a Disc Quality or Advanced Disc Quality scan to finish. I always end up getting this error below.

Nero CD-DVD Speed

Error!
PARAMETER VALUE INVALID (052602)

OK

Currently I have tried over a dozen times for this one disc and the best I got with a ADQ was over 51% before this error appeared. I have only gotten this to finsh once or twice since 4.7.0.0 was released.

Using the latest firewire 47P9.

How fast are you scanning the disk at and does it happen with other disks? I have that same drive and it scans any disk fine from start to finish but takes forever when scanning the Disc Quality when i select Maximum under the settings. How fast does the Disc Quality scan go for you?

Maybe try to uncheck some of the boxes and change some of the advanced settings.

IIRC that firmware will not work with CD-DVD Speed but 47N9 will. Anyone want to elaborate? (It’s been awhile) I have 47N9 .exe if you need it.

I just keep it at maximum which sometimes goes to about 10x. This has actually never really worked for any of my discs even before I had 47P9. Is it okay to flash 47N9?

I dont think it is the firmware because i have 47P9 and just ran a couple of dvds and they all finished and worked fine. You could give flashing to 47N9 a try though and see for yourself. Here are all the previous firmwares for this drive:

http://forum.rpc1.org/dl_firmware.php?download_id=2143

Thanks, seems to work now with 47L9 because 47N9 said to have some problem with CD-DVD Speed. Just got some no additional sense information errors now.



Hi, download and put Nero’s wnaspi32.dll in the same folder as cdspeed.exe and set your scan speed to 8X (the Forum standard for BenQ drives). :slight_smile:

Can’t download wnaspi32.dll from nero website but I already had a older version 2.0.1.68 in the same folder.

I am still getting the original Parameter Value Invalid error message with 47L9 firmware.

Downloads just fine here from my link above :confused:

What software do I need to download from ftp://ftp6.nero.com/wnaspi32.dll? Both IE7 and firefox can’t connect to download.

Here, I have uploaded it on the forum for you. I dont know why you cant connect and download it, the link works fine for me too.

Thanks for the file. Still getting the same error message.

Have you tested it on another PC? Maybe your USB drivers are messed up. Or try CDSpeed 4.60.

Haven’t tested on another PC yet, don’t have another to test on. Sometimes now a scan does complete. But how to I know if the disc was good or not? Do I just look at the quality score number.

Hi :slight_smile:
I have no idea why you need a wnaspi32,dll in the same folder as CD/DVDSpeed. It’s not necessary. I’ve never needed to do this. CD/DVDSpeed can/is a stand alone program.
However in case you feel a need for wnaspi32.dll & it may be giving problems try Frog Aspi :

@[B]zebadee[/B] - Putting the Nero wnaspi32.dll in the same folder as cdspeed.exe is recommended by the author of CDSpeed, both here and on the cdspeed2000.com website (especially for use with external drives). Indeed, in 99.99% of cases this is not necessary, but for troubleshooting it certainly cannot hurt.

@[B]Gamezgirl[/B] - The green read speed graph in the scan you posted above looks terrible. Your drive is not working well with CDSpeed. Since you indicate the problem happened after updating to the latest version 4.7.0.0, why don’t you try 4.60? 4.7.0.0 was a major overhaul and may have a problem with your setup.

Hi :slight_smile:
@ Cressida :- Well I’ve never needed it for internal or external - USB or Firewire. Just lucky I guess.(BTW I stand by my earlier post that the Frog Aspi is worth considering).
The BenQ external f/w is biased to USB setups. That’s not to say you won’t get good results with Firewire. Because you should. But USB by it’s very nature does not lend itself kindly to the continuity (found with Firewire) needed for some of these tests.

Is CD-DVD Speed supposed to work with the EW164B? My CD-DVD Speed (older and new versions) do not “see” the USB drive, but Nero and the Nero InfoTool both do . . . .

Than something is worng because I have the external EW164B and CD-DVD Speed sees it just fine as Zeb said without the winaspi32.dll in any folder.

Hi :slight_smile:
I’ve never had any problems myself. However my EW162I & EW164B were self built (1620 & 1640 crossflashed - then put into external closures).
It does appear that on some occasions downloading wnaspi32.dll & copying to the CD/DVDSpeed folder can help. Although this technique was originally intended for SCSI drives.It may help here.
N.B. As alan1476 has added (he’s had no problems either). The source of the problem may stem from the main system setup & not the external enclosure itself.
Anyway give it a try.