Error reading CD "Parameter is incorrect"

vbimport

#1

Hello.
I'm trying to read a CD that was burned by my boss using an unknown software (I suspect EZCd Creator or DirectCD).
On the CD, I see 2 sessions. One of 586mb and one of 2mb.

When I try to copy the files from the cd. I get the "Parameter is incorrect" error in Win2kPro and "Unable to read source file or Disk" in Win98.
I still can't copy the files on a Macintosh either.

I tried creating an ISO of the track I needed. I ended up with a 120mb .iso file. Which I find weird since I thought the ISO would the same size as the data on disk. When I mount the ISO using Daemon Tools, the mounted CD is 586mb CD, and I still get the "Parameter is Incorrect" error.

Is there a way for me to recuperate the data on the disk?
Any Ideas?
Thanks


#2

not really sure what to tell you…i always use isobuster for things that i think are a bit f*ed up…it should make some light of whats actually there


#3

I discovered IsoBusters yesterday. Great tool.
I managed to salvage 110 mb of data. Too bad for the rest.
Thankfully we have another backup…paper. We just need to retype everything now. doh! :slight_smile: