Error: Please insert DVD Disc or choose DVD folder/Image file

vbimport

#1

I recently purchased the "my name is earl’ Season 1 Dvd’s but can’t back them up. They play fine in my DVD player, but haven’t been able to decrypt them to my hard drive. Sometimes I have had partial decrypts, but now I get this message when I try. “Please insert DVD Disc or choose DVD folder/Image file” I updated my Nero as well as the firmware on the drive (Liteon DVD burner), but it doesn’t seem to make a difference. I just re-ripped my Hitchhiker’s guide to the Galaxy movie without a hitch, so the programs seem to be working fine. Anybody know what’s going on with this particular DVD series? Is there a new form of copy protection out there that’s not been beaten yet?

Thanks


#2

If you are using Nero then myself I would go to the Nero Forum for help


#3

I’m not using Nero to decrypt them. I’m using DVD fab decrypter 3.0.5.0. I have also tried using DVD Decrypter and it won’t see the disc either. I had previously been able to decrypt parts of some of these season dvd/s with errors, and then had problems shrinking/burning them with DVD shrink. I had posted in those forums and they had suggested 3 things: updating DVD burner firmware, Updating Nero (which does the burning for DVD shrink through that program), and removing Roxio drivers. I did all those things and still couldn’t burn successfully, so I decided to try re-ripping the discs, and now they wont even show up in my DVD drive. Sorry for being unclear earlier.

Thanks


#4

May want to update DVDFab Decrypter, you are a few versions behind :bigsmile:


#5

Agree with Tim on this as the latest version is 3.0.9.6


#6

I have a similar problem and it seems to affect any DVD I try. I have upgraded to DVDFab 3.0.9.6 with the same results. No matter what I do, I can not get DVDFab to recognize the DVD. The same DVD’s play fine using PowerDVD on the same computer.
I have also tried DVD Decryptor and I get a series of runtime errors when trying to access the same DVD’s.
Not sure where to start but I’m suspecting a underlying driver of sorts. I would appreciate any help…


#7

I downloaded and installed DVD Fab Platinum 3.0.9.8, and it doesn’t ‘see’ the DVD in the drive either. When I insert the DVD, it spins and makes some ‘beeping’ type noises that I don’t hear when I insert other DVD’s (beep beep- low tones; beep beep -low tone, high tone) and seems like it’s trying to recognize the media. It beeps for about 30 seconds, then spins down. If I go to My Computer, it lists the drive as a DVD Ram drive. If you try to explore it that way, it says to insert media.

Anyhow, the drive and programs seem to work flawlessly on ‘older’ commercial DVD’s.

THanks for your input. This is very vexing…


#8

Hi,
I have a blu-ray disc drive in a laptop, and it used to rip the blu-ray movies fine. I took the drive out and connected it to another computer to play a movie and then connected back to the original laptop. Now when I put in a blu-ray movie, it scans really quick, then doesn’t detect anything. It says, “Please insert DVD disc or choose DVD folder/image file”. But it used to work before now it doesn’t. I just downloaded DVDFab HD Decrypter thinking it older, I had 3.1.x.x, but it still doesn’t work any more. Any ideas?


#9

Same here.
I know that it worked before… I have 3 other BDs ripped vis DVDFab on the HDD.
Now it doesn’t even see the disc.
DVDFab does see “normal” DVDs fine.
Blu-ray Discs play great, just can’t rip them anymore.

:confused: