Error flashing my 7170A

Hello,

Got the AD-7170A with the original firmware, trying to flash to 1.o4 with liggy’s flasher.
When in safe mode, and trying to flash i get the following error:
“error submitting checksum”

I have attached a picture of it.

Any ideas anyone ?

Try forcing the drive into PIO mode in the BIOS.
I assume the drive is connected to an IDE channel and is not in an external enclosure.

It is indeed an internal drive connected to an IDE cable.
This is a new computer, with a gigabyte 965p DS3 rev3.3 board and in the bios i do not have any PIO options, just the following for each drive:
Extended IDE Drive - Auto/None
Access Mode - Large/Auto

tried all variations, still no luck in safe mode.

Any other ideas?

Oh, and thanks for the quick reply :stuck_out_tongue:

Large/Auto for an optical drive??

That sounds crazy.

I don’t know what to say, those are the options in the BIOS.
New board though, might this be a new approach ? I honestly have no idea…

Took the drive to a friend’s house, flashed it there, worked.
Drive works great now, finally.