Epson R300

vbimport

#1

Im haveing an issue with my R300 not printing on any media. All it does it take them in like all is fine but sends it right back out.

I have tried to uninstall all software and reinstall it. I have also gone through maintenance and cleaned the heads a couple time and did an alignment. I have also turned it off and on several time.

Last time I used it all work fine but the only difference from then to now is the media. Now I am useing hub printables, but i have also tried my other media and nothing works.

Any ideas or suggestions? :confused:


#2

I think this is a common problem with the R300, after a little use. I’ve found on mine, that I have to insert the tray just a hair more than I used to, in order to get it to work propertly. Sometimes I have to give it a little push as it is going in as well. I’m not sure if it is the rollers becoming glazed, or the cd tray itself, but I don’t having any problems if I give the tray a little push and/or start it out a little farther in.