Epson R280 printing error

vbimport

#1

I received my Epson R280 about a month ago and have been using it perfectly. Today i tried to use the CD/DVD tray on my Mac OS X snow leopard platform and it worked once. I have all the updates, so that is not a problem (i went over everything with an epson associate over the phone for about 30 minutes with him giving me step by step instructions)
Now when i try and print using my CD tray, it begins as it usually would and then the tray comes back out with the far right button being red. It also says that an error occurred on the printer icon that comes up when printing. Can someone please help me with this issue? Also i have tried restarting my printer numerous occasions and have checked to see if it still prints on paper. It does.


#2

the red button that lights up is the “paper out” button with the trashcan icon on it. also the power button is green while the paper out button is flashing.


#3

Moving your thread over to the ‘disc labeling and printing’ forum :slight_smile:


#4

Tried the SSC utility?


#5

when my epsons do that usually I can get it to work by pressing that button and making it pull the tray back in. They can be picky about getting the tray loaded just right and might get worse as thing wear and get dirty.
If it wont ever load no matter what maybe the printer has a issue or the tray is worn out or damaged or something similar.