Endless problems with Sony DW-D22A

Note: I originally posted this in the General Hardware forum by mistake, so administrators, please delete it there. =]


Hey guys,
I have this irritating problem with my nice Sony DW-D22A DVD-rw drive and I was wondering if anyone might shed some insight as to why it keeps screwing up. It’s a SONY DW-D22A unit, reflashed to firmware version: BYX5 and now running as a LITE-ON DVDRW SOHW-1633S, as is recommended all over the net. Here’s the list of symptons:

  1. The CD recording process seems to be fine, the real problem happens with DVDs. When I insert a recordable DVD of any format, the light stays solid green but it will spin up about 60% of the normal spin up growing high-pitched sound, then i’ll hear a faint CRUNCH and it’ll reset back to the lower pitch sound and rebuild back up to the 60% mark and recrunch, etc. etc. As a visual, it’s “zzzzZZZZZZZZZZZZ CRUNCH… zzzzzzzzzZZZZZZZZZZZZ CRUNCH… etc”

  2. That churning noise happens with any media I select, at any speed (usually chose 1x). I’m using both nice FUJIFILM DVD+R 8x disks which come individually in jcases, and also a spindel of 50 el-cheapo 2x CompUSA house-brand disks, both of which return the saaaaaaaame problem. I was considering going out and buying some Verbatims (TYs, or the actual brand TY instead) but they’re both expensive and if my drive keeps eating them, I’ll be evicted soon. LOL

  3. If I do manage to get the drive to stop freaking out, and I try to burn anything at anyspeed onto a DVD, it gives me a crashed disk error at about 3% or just after writing the lead-in section in the beginning of the blank DVD. I get a “BURN FAILED” error, and the disk is ruined. (These aint cheap, you know…)

Those items don’t happen with CD-rs, the CDs burn without a concern.

Can anyone please help? I have a brand new 250GB SATA drive showing up in a few hours to replace a faulty one, and I need to start backing up this data pronto. Thanks a lot! =]

fisherprice

EDIT: I just tried to run KProb2 to see if I might figure out the error, and at first the drive went into its normal mobius of ZZZZZZZZZZ CRUNCH and then finally stopped. It said “Detecting disk type…” for 5 minutes then it switched to “Done.” so I tried the test. I get a “Test Range Error” so I can’t even post a report! Please help =[

seems like a hardware failure.
call sony and ask for a replacement. flash back a 22a firmware before you send the drive back.

firmware binary: http://dhc014.rpc1.org/Files/DVDR/DW-D22A_BYS3b.zip
flash it with LtnFW: http://dhc014.rpc1.org/howto.htm