Ending of titles in mp3 tags disappeared



I ripped all my cd’s to harddisk in the mp3 format using EAC and L.A.M.E.
I just noticed that a lot of the song titels and album titles are suddenly capped at 30 characters! :eek:

For example (this is an extreme example obviously…):
The tag of the mp3 “There’s a Good Reason These Tables are Numbered Honey, You Just Haven’t Thought of it Yet” by Panic! at the Disco now has track title “There’s a Good Reason These Ta”:confused:

I’m 100% sure the tag (and all others that are capped now, which are quite a lot) used to be complete. The file name also shows the complete titles.

I think it has something to do with Foobar, because I don’t remember this problem occuring some weeks ago, when I still always used Windows Media Player for playing the music on my PC (now mostly Foobar, sometimes WMP).

Did Foobar steal the end of title tags just like that? :rolleyes:

I can repair the song titles by the file names, but that’s probably not a long term solution…


ID3 V1 tags truncate, V2 tags don’t. Try reading the other tag.


Alright thanks, I’m not sure how to do that, but I am pretty sure it is not the solution. See, I also use SonicStage and that software also reads incomplete tags now, and same in Windows Explorer. I can probably choose which tag to read in Foobar, but probably not in all other software, can I?


Install mp3tag [http://www.mp3tag.de/en/]. See if it will read the ID3v2 tags.

You may have to navigate through the options to force the software to only read ID3v2 tags. [Tools>Options>Tags>Mpeg>Read: ID3v2 only].

If, when reading only v2 tags, you do see the full title, you can choose to remove the ID3v1 tags. But first, make SURE that the files DO still have ID3v2 tags.

To remove the ID3v1 tags: Navigate to the same area in the options as when setting the software to only read v2 tags. This time, pay attention to the box labeled “Remove”, then make sure that only ID3v1 is selected and click “OK”. Then make sure all the files that you want to remove ID3v1 tags from are selected, and go to File>Remove Tags. This should remove the ID3v1 and force your players to read ID3v2, if the software supports it.


You might also have inadvertantly copied the ID3 V1 to the V2, in which case not much you can do about it, short of re-typing or using something like WinAmps ‘Auto Tag’…



not free but i really like using it.