Encode setting while Staxrip is encoding ( Aspect ratio ? or nothing to worry about )

i just updated my staxrip video encoding program from 2.1.3.0 to 2.4.0 and everything is encoding ok, but i noticed while it was encoding there is some info that i do not understand, in the line below in BOLD there are 2 sets of numbers, 368:363 , what are they ? in the previous version 2.1.3.0 it always said 0.0 as you can see here ----> y4m [info]: 1920x1080p 0:0 @ 24000/1001 fps (cfr)

i dont know if its anything to worry about or if there is a setting wrong that is causing it. as i did not change any settings at all when updating as all the settings were imported from the old version to the new version automatically in the setup process.

these are some of the spec of the encode while staxrip 2.4.0 is encoding below.

vpy [info]: using external Vapoursynth library from: “C:\Dean\Media programs 1\StaxRip x64\StaxRip\StaxRip 2.4.0\Apps\FrameServer\VapourSynth\VSScript.dll”
vpy [info]: VapourSynth Core R52
vpy [info]: 1920x1080 368:363 @ 24000/1001 fps (cfr)
vpy [info]: color matrix: bt709
x264 [info]: using SAR=368/363
x264 [info]: AVC Encoder x264 core 161 r3048+25 be33c5d [Mod by Patman]

If it is encoding as it should then nothing to worry about.
If you right click on the resulting encoded file then click on properties/details. It will show you the files resolution and frame rate among other useful into.

Probably the fact that the version you just updated to is the first build of version 2.4, May suggest its just a bug in the reporting.

While you are here.
How is the new PC build running?

hi Dee,
thanks for the info on that aspect. it does seem to play ok and all other info specs are also good. maybe like you said a bug in the text only.

New PC is going real good and fast, SSD is real nice, but due to me getting only 500gb SSD i am constantly looking at the space left over, as a fair few times i get to less than 50gb left, so i maybe looking at getting a 1tb SSD at a later date.
As my previous PC i had a 1tb HDD and it was perfect in size for what i do and never had to keep an eye out for drive space.

if i get a 1tb SSD is it just a matter of switching off pc , and screwing it into that 2nd SSD slot on the MOBO and then turn PC on and ready to go or will i need to put the new 1tb in the area where the current 500gb is and the 500gb in the spare slot. if its a little more complicated than that ill touch back with you when the time comes to do it. as i will want to create an image of the current SSD and then apply it to the New 1tb i get. and then use the 500gb as backup or spare drive.

If your PC was built properly by the vendor then the existing M2 SSD should be installed in the M2 socket that connects directly to the CPU.
You could put the 2nd SSD (1TB) in the other socket and it should work properly. But you’ll get the best performance from the 1TB SSD if its connected to the existing M2 socket.

Before going down that route. Have you done a Windows 10 Disk Cleanup to remove left over temp and upgrade files?

Open your file explorer then right click on your C:\ Drive, and then select properties.
Now select the Disk Cleanup icon.
Once done you should a dialog like the following.

1

Now select ‘clean up system files’ option.

2

Look at the selectable options. And look for ‘Windows update’ and Old Windows installation.
Select any of those options that appear.

Now select the ‘more options’ tab

3

Now select the option for System Restore and Shadow copies clean up.
Now OK the selections. You should get a warning telling you its going to delete files. OK it.
Now let it do its stuff and see how much space you have left once its complete.
You will need to close file explorer and then reopen it to see the changes.

thanks, will keep an eye out for that in the future, i had about 5 restore points that were saved there. But still may look into a 1tb in the future.

i have another issue about webpages loading slow while using a VPN, on my win7 PC the pages were quite fast with the VPN, but on win 10 the same sites most of the time they are taking 20 - 30 seconds to load up. i will create another thread on this in the coming weeks when i have time. appreciate your time as always.

@ DJmoonwalker your post shows this: \VSScript.dll

If you don’t mind what format video are you working with ?

I’m using the newest 32-bit version of Staxrip.
I hadn’t used Staxrip in a long time.
I saw your post so I updated & gave it a try.
I do have a couple of computers that are 64-bit but I use my 32-bit most.

I’m not getting any y4m [info] or vpy[info] like you are.
I do get x264 [info] but it doesn’t show the SAR.

hi Cot, get comfortable and grab a beer lol. bit of info below.

The video i’m working with 1920x1080p x264 video and outputting it as x264 MKV using ac3 audio.

Regarding the version I’m using - its the 64bit version.

my previous version of staxrip was StaxRip-x64-2.1.3.0, the only reason i updated it to 4.2.0 was due to 2.1.3.0 version not being able to import videos with long file names when adding a movie into it for most of this year for no apparent reason as i didn’t update anything in staxrip , but maybe a windows update had something to do with it., it would constant say something about file name too long , or too many characters. so i was forever shortening the file name so it would import into it. but after updating to the newest build a few things started not working as they did previously. i always like to have the latest version too, just in case there’s new features or something like that.

( I dont see the y4m text in the newest updated version anywhere.)

as for the y4m , i dont know what that is but i just did a small sample encode in version 2.1.30 and it has the word demuxer in front of it, see several items below which i highlighted in BOLD


“C:\Media programs 1\StaxRip x64\StaxRip\StaxRip-x64-2.1.3.0\Apps\FrameServer\VapourSynth\vspipe.exe” “C:\HQ Vids\To convert\21.2008.BluRay.1080p.TrueHD.5.1.AVC.REMUX-FraMeSToR_temp\2 SToR .vpy” - –y4m | “C:\Media programs 1\StaxRip x64\StaxRip\StaxRip-x64-2.1.3.0\Apps\Encoders\x264\x264.exe” --pass 1 --bitrate 6500 --preset slower --profile high --level 4.1 --partitions none --no-fast-pskip --no-mixed-refs --no-mbtree --subme 10 --no-weightb --rc-lookahead 120 --ref 4 --no-dct-decimate --videoformat ntsc --colorprim bt709 --colormatrix bt709 --transfer bt709 --input-depth 8 --muxer mkv –demuxer y4m --frames 1033 --stats “C:\HQ Vids\To convert\21.2008.BluRay.1080p.TrueHD.5.1.AVC.REMUX-FraMeSToR_temp\2 SToR .stats” --output NUL -

y4m [info]: 1920x800p 0:0 @ 24000/1001 fps (cfr)
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2 AVX FMA3 BMI2 AVX2
x264 [info]: profile Main, level 4.1, 4:2:0, 8-bit

also i am using the vapoursynth “VSFilter” which is located on the Mid left of the app, as there are 2 to choose from Avisynth or VS Filter, i used to use avisynth , but then changed to vapoursynth filter “VS Filter” , as the encodes processed 50% - 100% faster, with no difference in quality. So thats where the vpy[info] may be coming from.

as for that aspect ratio error, i just did some testing , by disabling a tonne of different things one by one to isolate the issue, still could not find out why, then i disabled the filters i use one by one, and found that the MCTemporalDenoise filter was the one causing it. if i disable it the encode says 1:1 or 0:0 as it should, but as soon as i renable it , the error comes back. see if you can reproduce this. In the filter list goto Noise --> MCTemporalDenoise , i also use SMDegrain “very low” as well most of the time with it. but is definately the MCTemporalDenoise causing it. and also if the cropping of a video is slightly out it will also give that same 368:363 aspect error be it those numbers or slightly different. but regardless those numbers are hugely different to what it should be --> 1:1

i have also noticed a few other annoying small issues with this latest version, like when you save the project, Pressing File, then save Profile, it then creates an .srip file whcih u can double click to load up at a later time if you like, so what i notice is on the right side of the Staxrip app you have a small white area that says presets, Tune, options, and just above that you have your saved templates or where you can Copy/mux etc… well when i have my custom loadup profile settings there, and i go to reload that .srip file that custom preset reverts back to default ( x265) preset is loaded. and all audio in the bottom section is now blank too.

Aslo unable to force an aspect ratio from 2:35 to 2:40 using the resize option or vise versa. where as in previous i could.

@ [DJmoonwalker
I found out the 32 bit version doesn’t have VapourSynth.
So I had to get the 64 bit version for my laptop.
I will try on my HTPC but I didn’t have time today.

For a long file name did you use the _ between the words ?
Like the video I converted Call_of_The_Wild_Harrison.mp4

I tried to use y4m but it cause an Error that I was missing winerror.h .
So the conversion Failed.
When I tried to use MCTemporalDenoise it errors & said this file was missing OpenCL.dll missing…
I had to use Task Manager End Process to shut that down.

The SAR stayed at 1/1 because I couldn’t make the settings that caused the problem for you.

It does always revert back to the ( x265) preset Default.

Here is information from the StaxRip log:
------------------------- VapourSynth Script -------------------------

import os, sys
import vapoursynth as vs
core = vs.get_core()

sys.path.append(r"C:\Users\USER\Desktop\StaxRip-v2.4.0-x64\Apps\Plugins\VS\Scripts")
core.std.LoadPlugin(r"C:\Users\USER\Desktop\StaxRip-v2.4.0-x64\Apps\Plugins\Dual\L-

SMASH-Works\LSMASHSource.dll", altsearchpath=True)
clip = core.lsmas.LibavSMASHSource(r"C:\Users\USER\Desktop\VIDEO

\Call_of_The_Wild_Harrison.mp4")
clip.set_output()

x264 0.161.3048+25-gcc10.2.0 Patman Mod

C:\Users\USER\Desktop\StaxRip-v2.4.0-x64\Apps\Encoders\x264\x264.exe --bitrate 6500 –

preset slower --profile high --level 4.1 --videoformat ntsc --colorprim bt709 --colormatrix bt709

–transfer bt709 --muxer mkv --fps 24000/1001 --synth-lib C:\Users\USER\Desktop\StaxRip-

v2.4.0-x64\Apps\FrameServer\VapourSynth\VSScript.dll --output C:\Users\USER\Desktop

\VIDEO\Call_of_The_Wild_Harrison_temp\Call_of_The_Wild_Harrison_out.mkv C:\Users

\USER\Desktop\VIDEO\Call_of_The_Wild_Harrison_temp\Call_of_The_Wild_Harrison.vpy

vpy [info]: using external Vapoursynth library from: "C:\Users\USER\Desktop\StaxRip-v2.4.0

-x64\Apps\FrameServer\VapourSynth\VSScript.dll"
vpy [info]: VapourSynth Core R52
vpy [info]: 1920x1080 1:1 @ 167920/7007 fps (cfr)
vpy [info]: color matrix: bt709
x264 [info]: using SAR=1/1
x264 [info]: AVC Encoder x264 core 161 r3048+25 be33c5d [Mod by Patman]
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 Cache64
x264 [info]: profile: High, level: 4.1, subsampling: 4:2:0, bit-depth: 8-bit

hi COT,

  • take your time no rush, just good to have help if problem can be solved.

with the files names there are no underscores “_” between each word or dots. just gaps. the total number of letters and gaps when the error occurs are about 95, although can be longer or a bit shorter as well, and will still get the error below popping up. so i have just been shortening the title and after the encode pasting the original text back. thats sort of my fix for now. the newer version of staxrip 2.4.0 has fixed this issue. so at the moment the long text thing is sort of not a great issue. just in case here below is the error for the long text being to long

Source file path or filename is too long

In theory Windows supports paths that are longer than 260 characters, in reality neither Windows, nor the .NET Framework or the used tools have full long path support. ( My text was less than 100 so thats why i dont know why its giving that error. )

  • regarding y4m , i dont really see that at all in the new version. so cant help you there, it may of just been an older way of demuxing or muxing or whatever it does in the version 2.1.3.0 i was using.

  • Do u have the MCTemporalDenoise filter in one of your plug in folders ?

  • ( x265) preset Default. this is a little annoying having it always going back to x265 on loadup of a saved template. ill go through the settings to see if it can be adjusted. but may just be a bug.everything else looks ok in those x264 settings.

The reason I posted about the “_” is I use ffmpeg for some encoding & it doesn’t work with gaps in file names.

I did some testing with my HTPC .

LibavSMASHSource used set to vapoursynth.
In the Resize box:
DAR 1.77777
SAR 1.77777
PAR 1:1

force -crf added
vpy[info]: 1920x1080 1:1 @ 167920/7007 fps (cfr)
x264 [info]: using SAR=1/1
Same with force CBR
same with both checked

With MCTemporalDenoise filter checked:
vpy [info]: 1920x1080 368:363 @ 167920/7007 fps (cfr)
x264 [info]: using SAR=368/363

Plugins
AVS folder has MCTemporalDenoise filter
VS folder does not have MCTemporalDenoise filter

No y4m in any folder
This is the error:
C:\Users\TV\Desktop\TEMP\Call_of_The_Wild_Harrison_temp\Call_of_The_Wild_Harrison_out.h264’ could not be opened for reading: end of file error.
This may have been caused because I used a short clip for testing.

How & where do you make this setting:

force an aspect ratio from 2:35 to 2:40 using the resize option or vise versa

I tried the Resize sllder but it just changes the height & width.
It doesn’t use the aspect ratio.