Enable Smart Encode w/ NeroVision api

What video files format must be referenced in the XML file for the NeroVision API to cause it NOT to transcode the file? I have tried a 720x480 MPEG-2 w/ 4x3 aspect ratio and DVD legal bit rate. Yet it still take a long time to transcode it?

You should try to analyze the file with the MediaAnalyzer object before calling CreateNeroBurnContext. Additionally the MPEG profile of the file needs to match the target profile.

I’m having the same problem with NVAPI, but analyzing the video files with the IMediaAnalyzer interface did not help (an example video took 7 min. in NVE but approx. 2 hours with NVAPI to encode).
Are there any restrictions or things to consider when using the MediaAnalyzer in order to enable SmartEncoding?

Maybe you forgot to set the correct target video format (NTSC or PAL, made in NVE automatically) which differs from the source format?

No, I have set project type to “PAL” and append it to the NV project:


IXMLDOMElementPtr pProjectType;
pProjectType = pDocument->createElement( pType );
pProjectType->setAttribute( "encoding", "PAL" );
pNeroProjectElement->appendChild( pProjectType );

As far as I see, my MPEG2 should also be standard-compliant.
Can it depend from the NV version?

It is importand, the MPEG2 source stream contains video also in PAL.

This seemed so obvious to me that I forgot to mention :wink:
Yes, they are in PAL format, too.