Emprex DVDRW IDE H16X Flash Failure

vbimport

#1

I just purchased an Emerex DVDRW IDE H16X. Like a fool I installed the liveupdate program and upgraded to the latest firmware version. All went well. Got the message to restart.
Now the drive is DEAD.
I can’t even push the button to open the drive.

I went to the liveupdate site looking for the DOS flash utility. It isn’t there. I haven’t gotten an answer back from them yet.

Does anyone have any ideas? I can’t find the flash on the internet.

Tom W.


#2

Guess I should say what the versions were…
This was an emperex DVDRW2016IM going from firmware version B02H to version B02K.


#3

Have you already tried mtkflash + a binary version of the firmware?
If that thingy’s using a Mediatek chipset then it might be able to resurrect your device.


#4

I need to get a binary image. If anyone has one of these drives, I’d be forever in your debt if you could copy it off for me…


#5

Check your c:\windows emp directory there you should find a folder beginnig with PAC….
In this folder contains the firmware.bin file and you can use this file to recover the drive.


#6

Hi Tomlw,

As H3rB3i pointed out in PAC… folders there should be 5 files (3.bin, .txt and .exe) . Just double click .exe file and reflash the drive again. It should work. Good Luck.


#7

There are two bin files if I’m correct (loader.bin and the firmware file 0450.bin for example) ;).

You can’t flash the drive when it’s not detected in windows. The only chance to recover the drive is a flash in DOS.


#8

I got the files. Tried multiple versions of MTKFLASH. When I try to write it just locks up.


#9

Have you tried with the DOS version in REAL DOS?


#10

I used a drive freshly formatted with dos 6.0. No autoexec, no config.sys. No other drives except the DVD burner, that I connected after booting up. I tried 3 versions of MTKFlash, the last of which was 1.83. In all cases, when it tries to do anything with the drive it locks up.


#11

I used a drive freshly formatted with dos 6.0. No autoexec, no config.sys.

a simple DOS bootdisc (downloaded from www.bootdisc.com) is enough for the job. Also, you need the config.sys to load the device drivers.

have you connected an other drive while booting up?

There are no drivers loaded in case that the drive isn’t recognised by your PC while booting up. So you have to connect an other drive during the bootprocess and to flash the “dead” drive after you have connected it instead of the working one.

P.S. connect both drives to the psu and just remove the IDE cable from the working drive and connect it to the dead one after booting up. Also, make sure that the drive is set to master or slave and not cable select.