Empire earth install

vbimport

#1

Hello all,

I have been trying to install empire earth. I click install, and an install shield maintenance window pops up with the following 2 options. Repair or remove. I have tried both several times and it tells me the problem is fixed… but believe me it isn’t.
Secondly, I have tried to uninstall and re-install but my computer won’t uninstall, it again puts me back to that stupid maintenance thing.
Thirdly… sometimes another window pops up with this message" this application has failed to start because sxlrt233.dll was not found. Re-installing the application may fix the problem."
This was done now I have yet another message coming up saying"low-level engine.ddl missing" Are these errors EVER going to end?
All I can hope for is somebody to please help!!!


#2

Sometimes you have no choice but to do a manual uninstall; locate the “Empire Earth” or “Sierra Entertainment” game folders in Windows Explorer and delete them all. You may also need to search in the Windows Temp folders and the following folders as well for related “Sierra Entertainment” folders and files and delete them all:

\Documents and Settings\your username\Application Data
\Documents and Settings\your username\Local Settings\Application Data

Then open the Windows Registry and delete all related “Empire Earth” and “Sierra Entertainment” entries. Use the search function to make sure you have found all entries.

Once you have successfully removed all traces, reboot, and then try to re-install the game.


#3

Thank you for your help. I have done all you suggested except the windows registry one because I have no clue how to do that.

I still can’t uninstall through the install/uninstall programs page.
Everytime I try it brings me back to the repair or remove page once again.


#4

Try downloading CCleaner to clean the registry. You can also use it to uninstall programs. It’s free program and you can read up on it here: http://www.ccleaner.com/


#5

[QUOTE=sikoone;2121410]Try downloading CCleaner to clean the registry. You can also use it to uninstall programs. It’s free program and you can read up on it here: http://www.ccleaner.com/[/QUOTE]

I too have the same problem with my favorite game: Empire Earth. I have downloaded and run the registry cleaner after manually removing all Registry Entries to Empire Earth, Sierra, and Mad Dog. Before this all files & directories were deleted. However nothing works: the game will only give options to uninstall or repair: neither of which seems to transfer/delete any files.

I guess whoever programmed the install/uninstall program for EE wasn’t very good.


#6

ouch its a shame to see such issues EE is one of my all time favorite games. Ive been playing EE EEaoc since it came out almost 7 years :confused: its always played flawlessly for me on multiple systems and builds. Look me up on multiplayer im Blaircroft.


#7

Actually those Cleaners are all pretty worthless. I did get it to work by deleting files found in the Install shield info.

I tend to be addicted to it so my wife tries to hide the disks & I uninstall it frequently so as to prevent my playing it. I have some good scenarios [single player] that I’ve written.

It works now: I was able to install it.

I’ll try to look you up I’ve only once played multiplayer & then it was co-op. I’d probably stink playing against a human.


#8

Okay, here is what worked for me:

First you will have to unhide hidden files and folders in Windows Explorer.
How to do that can be found in below link.
http://www.optimizingpc.com/install/windowsxpsettings2.html

Remember to close Windows Explorer after making the changes so the changes can take effect.

Next step is finding the correct folder on your harddisk.

In Windows Explorer navigate to C:\Program Files*\InstallShield Installation Information

In the “InstallShield Installation Information” folder there are a number of folders with strange names like {21C41BAF-6F62-469D-A43B-DDF01628346E} (this one is for Ground Control II). Open those folders one at a time, in it locate setup.ini and open it with Notepad. Check the line where it says AppName= if it says Empire Earth. When you find the correct folder with the strange file name, rename that folder by adding something like aaaa to the foldername (e.g. in my case the folder name would become aaaa{21C41BAF-6F62-469D-A43B-DDF01628346E}).

EE: AoC most likely has its own uninstallation folder so you will have to check all the folders with strange names for being sure you got everything deleted.

Close the folder you just renamed, open it again and check in setup.ini that you renamed the correct folder. If you did, then delete the folder you renamed. If you renamed the wrong folder, rename it back by removing the letters you added and continue the search.

You might like to copy and save the original name of the folder(s) you delete. This is because the names are also to be found in the registry, and sometimes one also have to delete the strange foldernames there. If after deleting the folder(s) with strange names, you still get that error message, please report back and I will guide your through manually deleting the obsolete keys in the registry.

WARNING: If you delete the wrong folder and are unable to restore it from the Recycle Bin you will be unable to uninstall the program the folder belongs to in Add and remove programs but will have to do so manually. Some times this is pretty easy but other times it’s almost impossible.