Eject can't clear previous mounted disk

vbimport

#1

has anyone taken noticed or encountered the problem where sometimes the disk name of a prevoius mounted disk does not cancel after eject?
Problem no.2 - eject button is sometimes disabled after mounting the disk. depending on the software, you can eject only from either win explorer or from the software’s menu if it has Eject.

The problem here is Roxio6 drag-to-disk for example, can’t notice a different disk has been inserted! It still reads the new disk name as the previous disk!
Nero too can’t cancel name of previous mounted disk after eject.
I’ve tried many different softwares over 6 different cd & dvd drives - Plextor, LG, Lite-on, BenQ, Aopen, Mistumi, u name it, but the same drive locker problem! Can’t clear previous mounted disk sometimes but not always.
What is responsible for that problem in the first place?
Is it (a) windows problem? (b) the burner software problem? © the drive problem?
What is the solution to it?
When swapping disks during multisession burn, the problem becomes problematic. After the software reads the 1st disk into the compilation window and request insert 2nd disk, it continues to read any replacement disk as the 1st disk and spits it out.
That’s when the problem sucks!
What is the solution to cancel name of a previous mounted disk for all burning software?


#2

Are you using Sonic DLA or DirectCD? If yes, try to disable it.
Windows has problems as well “forgetting” the last mounted disc. Installing and running AnyDVD usually will cure this.


#3

First: uninstall any Roxio programs. DirectCD usually causes problems like this. Try Nero’s InCD and see if your problem disappears.


#4

I’m not sure about Roxio, I have not used it in a long time but DVD Devrypter has in the device tab for the tray to check during a read write or erase and a box to check for disable media change notification. Maybe something like this in Roxio that you have checked.


#5

Thanks all for your quick helpful tips
For a while, i also suspected windows as the culprit because the problem exists in every burner software - it does not matter which one.
It usually refuse to clear the name of of previous mounted disk during disk swap.
The problem makes burning from multiple disk sources imposible no matter which software i use. The only software i have not yet tried is decrypter suggested by jim1647


#6

Yes windows problem have noticed it myself but really just did not worry about it. Another thing I have notice with roxio, nero and most other coping software is that if you make a copy of say a program disk that should start when you insert the disk it will not until you have restarted the computer. I just assume that roxio nero and the others disable the auto start on insertion of the disk since it could cause problems with there software and when you leave the program it does not always restart it. Had a friend make a copy of a program disk that should start the install program when you insert the disk for me and they told me that it would not auto start for them after they had made the copy with clonecd. When I tried it on my computer it went to the install as soon as I inserted the disk. I then informed the person who gave me this disk that this is not uncommon it has happen for years and that there is not anything wrong with the copy of the program on the disk you just need to restart your computer then insert the disk and it will auto start.

Both the can’t clear the mounted disk and the auto insertion problem have been there for years but since I know they happen it really is not anything I worry about.