Easy to solve

Neither Nero 6 or Ezy CD 5 detect my new BTC CD-RW 52x24 with WinXP. I tried to update the firmware with V001U.exe (IDPFLIRW5224V001U.EXE) but it displays the message “Drive Model doesnt match!”. It is the correct one (well, it should be!) so I dont know what to do coz no software detects the drive and drivers seem to be ok.

No Thread seems to talk about what that “Drive model doesnt match” means so I dont know what else to try.

Please help!!

Hi,

Your CDRW is a 52x24x52 BTC BCE 5224IM according to the Windows version firmware you’ve downloaded.

Perform a systematic hardware diagnostic as follows:

  1. disconnect the power lead from the wall socket and open the case;

  2. touch a metal part of the chasis, and verify that the PSU is rated atleast 300W minimum (that should properly power 1 HDD, 1 Floppy, 1 DVDROM and 1 CDRW);

  3. disconnect the IDE cable and inspect it for defects; temporarily replace it with a known working cable if possible and connect it to IDE2 on the motherboard.

Remember to align the red stripe on the cable with pin 1 on the motherboard, and nearest the power input socket on the CDRW.

Set the jumper on the CDRW to ‘MA’ (for Master).

  1. now, connect the power lead and boot the machine.

Access the BIOS setup screen, press the eject button on the CDRW to make sure that it is receiving power, and enable the ‘Master’ channel on the Secondary IDE (ie IDE2). Set it to Auto detect the drive;

  1. save settings and exit the BIOS.

  2. when the machine reboots, verify that the CDRW is detected by the BIOS by pressing <Pause/Break> at the POST status screen or re-enter the BIOS - it should be listed by its model name, probably ‘BTC BCE 5224IM’;

  3. if steps 1-6 completed successfully, then you we know that it is less likely to be a hardware fault and more likely a software one;

  4. now, boot to WinXP with Administrator priviledges.

Go to Start>Run and type services.msc.

Click the ‘Status’ heading to sort the services that have been started by Windows. Make sure that ‘Shell Hardware Detection’ has not been disabled - re-enable and start it if it has.

  1. now, go to the Device Manager, right-click and remove any CD/RW devices that exhibit the hardware fault icon.

Right-click and select the Scan for hardware changes.

  1. if WinXP successfully detects the drive, then you are almost done.

  2. screw the case back on.

To flash the drive, download the DOS version firmware and reduce the system Ram to less than 256MB.

Create a DOS boot floppy and make sure that no memory managers or device drivers are loaded prior to flashing.

Tell me how you get on.

Thanks 4 your help.

Hardware checking done. Even new IDE cable. Device´s Jumper as Master. BIOS configuration Ok. Device Manager with no unit problems. Drivers correct. Shell Hardware Detection enabled.

Now comes the funny bit. Burning aplications (Nero 6 or Ezy CD 5) no always detect the CD-RW unit EVEN WHEN WinXP DOES!!!

I can burn a CD with no problem to find out that the unit has disapered from the Unit Selector or Drive Information from those aplications when I want to burn a second CD. Then I have to reboot wich doesnt always ensure that it will be detected by the burning aplications despite the fact that Windows ALWAYS does!!!

Devices normally do work or dont work at all… in this case it does… sometimes… but not always. Wich makes it really dificult to find the foult.

Hi edgtron,

It IS a software issue - in particular Ezy CD 5 (as revealed by the diagnostic steps).

But just to be sure I dug out a few of my old OEM and Deluxe editions of Adaptec/Roxio EasyCD Creator and did test setups on 3 XP machines preinstalled with Nero 6.0.

On each machine Roxio would either fail to complete a burn or would complete with errors; each case requiring a reboot before additional burning steps could be complete.

The best solution is to un-install Roxio (and its associated ASPI layer files) as it’s just duplicating the more than adequate functions of Nero.

You could also try other more powerful and smaller burning utilities such as CloneCD/DVD, Blindwrite, Alcohol…

Incidentally, when installing new software always choose the ‘Custom’ option if there is one.

Don’t install rubbish like animated helpers or program launchers as these offer little functionality for the system resources they consume.

The second best solution is to apply the most recent updates to Roxio that also includes WinXP compatability fixes.

You may find the solution suggested above may also solve the ‘Drive Model doesnt match!’ problem.

I’ve only encountered this particular problem 7 times. All have happened when attempting to flash OEM drives - that is to say, drives built and labelled by one manufacturer, but modified by another (eg Asus 52x24x52 are actually Optorite drives).

Hope this helps.

BTW, please don’t start a new thread regarding this issue everytime you wish to post a response - use the ‘Post Reply’ button instead.

I am having almost exactly the same problem. I am running Windows 95, and have the same CD/RW drive. The drive was working fine, until I put a second HDD into the computer. I moved the CD/RW drive to a different IDE cable, and added the new hard drive in the place where the CD/RW was. The CD/RW drive now does not show up in windows, and is not recognised by Nero, although it does show up in the BIOS. It does not show up in the device manager either. I cannot run services as described above, since I am running Win95. I have had a similar problem with another drive on another computer, and the problem was easily solved by removing the registry keys for the drive. However, I do not know where to find the registry keys for this drive.

Does anyone know how to fix this problem, or where I can find the registry keys?

@scars

Attempt at a solution of your problem:

  1. If you have an Award BIOS, you should have a section PNP/PCI Configurations or similar. If you have an entry “Reset Configuration Data”, set it to “Enabled”. Save and boot into Windows.

Does Windows see your CDRW now? Problem gone then. If Windows does not see the drive, do the following:

  1. Temporarily disconnect your 2nd HDD.

  2. Temporarily reinstall your CDRW to the original IDE port. Boot up, and chances are that Windows will recognize your CDRW again.

  3. Delete your CDRW from the device manager and shut down your computer.

  4. Disconnect your CDRW and reboot.

  5. Shut down your computer again.

  6. Reconnect both your HDD and your CDRW.

Let’s know whether it worked for you.

Regards, Martin A

I tried everything you suggested, still nothing. I have tried the CD-RW drive in every IDE port, with and without the new HDD. Even if I have it exactly as it was previously configured with the HDD set as the Secondary master & the CD-RW set as secondary slave, no 2nd HDD, it will not work. The CD-RW drive does not show up in device manager either. Any ideas???

Hmmmmm…

Which drive is connected to which IDE port on your machine?

And - sorry for asking and no offense meant, but sometimes it’s just the obvious that will escape us: how about your master/slave/cable select jumpers?

Afterthought: are you sure that it’s not your IDE cables which are to blame (40/80 wires, cable length?) Can you, just temporarily for testing and for definitely excluding one more possible source of trouble, install another IDE cable which is known to work like it should?

Regards, Martin A