Eastern Promises

vbimport

#1

I burned the movie Eastern Promises with dvd fab 5 platiun which contains subtitles. I used main movie mode. When i played it back on my dvd player I noticed there were no subtitles. I reburned it on full disc mode and then the subtitles were there. What did I do wrong in main movie mode to not include the subtitles? Did I forget to set something? Thanks for any help on this.


#2

[QUOTE=tjlc99;2064420]I burned the movie Eastern Promises with dvd fab 5 platiun which contains subtitles. I used main movie mode. When i played it back on my dvd player I noticed there were no subtitles. I reburned it on full disc mode and then the subtitles were there. What did I do wrong in main movie mode to not include the subtitles? Did I forget to set something? Thanks for any help on this.[/QUOTE]

Open common settings and on the left side click on "Streams->"Subpictures"
in the window on the left select the language of the subtitle you want and click on the >> button to move it to the window on the right, and make sure you put a tick for “Preselect the following subpicture tracks”


#3

Thank you Stormjumper, I will do that. Thanks again.


#4

The Russian/Turkish translations for this movie are contained in the second (lower) set of Engllish subtitles (0x23). If you use Main Movie (or Customize/No Menus) they will not play automatically unless you turn on the default arrow (see the [B]Tutorial[/B]). There are no subpicture forced start commands in the VOBs for Eastern Promises, so you have to make them play by default or use a copy mode that preserves the original IFOs (Full Disc, Clone, Customize+Menus, Split). The settings stormjumper suggested will include them in your backup but will not make them play automatically.


#5

So, if there are 2 subtitle options in Eastern Promises or any movie like that, should the default arrow point toward the first or second subpicture option?. I guess I don’t fully understand how the green arrow works and what it means exactly when it’s on or off, sorry maybe a stupid question. Thanks for any help.


#6

[quote=tjlc99;2064726]So, if there are 2 subtitle options in Eastern Promises or any movie like that, should the default arrow point toward the first or second subpicture option?. I guess I don’t fully understand how the green arrow works and what it means exactly when it’s on or off, sorry maybe a stupid question. Thanks for any help.[/quote]The problem is that there is no “standard” way to make translation subtitles appear on the screen in a DVD, so don’t feel bad.:slight_smile: The default arrow should point to the second (lower) English subpicture selection in Eastern Promises, but this will not be true for every movie. Sometimes all of the subtitles, full dialogue and translation, are all in the same stream (DaVinci code I think was this way). I test these two ways, by playing back with WinDVD on my PC and seeing what happens as I change subtitle settings and second the excellent free program DVDSubEdit, which will read the VOB files that hold the movie content and show you the subtitles and tell you whether or not they have a “forced start”, i.e. they will appear on the screen even without the default arrow in Main Movie mode. It can be confusing, so try experimenting if you have a movie with translations by ripping a few chapters to a HDD folder and see how they play back. Change the settings and try again if you don’t get the results you wanted. And again, you can avoid all this by using the “non-reauthor” modes within DVDFab (Full Disc etc.), which should make the subtitles on your backup work just like the original.


#7

Signals, thank you very much for taking the time to help. Very useful and interesting info. Also, thanks again to others who have helped me so far. I know full disc mode will avoid this problem, but doesn’t main movie mode give a better quality backup because of less compression used to fit on a s/l disk?


#8

You’re very welcome. :slight_smile: Don’t hesitate to ask questions in the forum, someone will always come along and help.