EAC problem

I’ve been using EAC to rip CD’s in the past with no problem until today. When I try to play the CD in EAC, all I get is a constant clicking sound. If I rip the track into wav files and try to play those, I get the same clicking sound and no music. The CD plays fine in Windows Explorer and I can see the CD and track listings in EAC.

Things I’ve tried:

  1. reinstalling the program (as per this guide http://chrismyden.com/bestmp3guide.php)
  2. played with “Use alternative CD play routines” in the options box
  3. tried all the “Drive Read Commands” options

I have two optical drives (Benq 1655 and Sony CRX230E) on this machine and both drives have the same problem. My other computer works fine with the same setup and I’ve googled for hours to no solution. Any ideas?

Yo-

And the media is…

And the speed that I am burning is…

And my operating system is…

-eh?

I’m using XP pro. The media I’m trying to rip are store bought pressed CD’s.

sounds like they have a copy protection , scan the cd with copy discovery

Yo-

Again - what media are you trying to burn to and at what speed-eh?

Big fella he’s not trying to burn he’s trying to read!!!
And yes it’s a copy protection

Yo SK-

OP says that he has ‘clicking’ when he [I]plays[/I] the burned CD - hence - the media being burned to and speed questions-eh! :slight_smile:

(although - in reading again - it is possible that they are trying to use EAC as the player program of the pressed CD-eh?) :doh:

no he has the clicking sound when he plays the rip. and it does sound like a copy protection.

one possible method would be to rip the disc to ISO using whatever ISO extraction program you like then mount the iso on a virtual drive and use EAC to rip from the virtual drive.

sometimes that will do the trick for copy protected cds.

Sorry if I wasn’t clear about the problem, but yes it’s a reading problem I’m having, not burning. I wish I was at the burning stage tho :sad:

It’s not a copy-protection issue AFAIK, I tried putting in a burnt CD and it does the same. I’ve tried many other CD’s with no luck. I’m sure it’s not a protection problem because I’ve ripped my entire collection of older CD’s in the past with no problem up until now. The odd thing is that if I click on my drive in Windows I can play the CD fine. The only reason why I even noticed the whole “clicking” thing is because I tried ripping a CD today and all the files are basically nothing with a faint clicking noise.

I even looked at the log text file that EAC generates after you rip, nothing is out of the ordinary. I’ve uninstalled/reinstalled the program and drives with no luck so far. I was thinking maybe my optical drives were broken, but why would the CD play fine outside of EAC?

thanks.

i’m stumped then. it’s got to be something about the computer or the EAC settings themselves. the discs play fine you said, and the odds of having the same problem at the same time with 2 drives…not good

i know EAC has a lot of options, and i’m sure you’ve doublechecked them, but just for the sake of being thorough, be sure you’ve doublechecked your options. whether you’re ripping to FLAC or mp3 a wrong command line switch shouldn’t cause the error…it would just output wavs instead of what you wanted.

can you use EAC to rip in any format? do wav files work?

also just to double check that it’s not your drives, can you rip using another program? even if you just try with itunes or something it would verify this.

i’m pretty decent with EAC, but you sound pretty competent with it as well. can you post the log here in [ code] [/code ] tags? If you didn’t find anything wrong with it, I probably won’t either, but it can’t hurt.

i just realized the guide you posted recommends an olde rversion of LAME and gives preset configurations. can you tell me which config you were using from that site and I’ll dl and take a look at it?

in the meantime, can you make sure you’re using the latest version of the LAME and FLAC encoders? (3.97 and 1.1.4 respectively i believe)

i don’t think FLAC command line switches would change, but your LAME command line would be different now if you’re using an older version. if you need help with that let me konw.

try this , goto the EAC folder and delete the profiles folder , then goto start–>run–>regedit , expand “HKEY_CURRENT_USER\SOFTWARE” and delete the “AWSoftware” key (EAC stores its settings there) and close the registry editor, run EAC , the wizard window will popup just configure it all over again , then try to rip again

I’ve been trying everyone’s suggestions with no luck, as well as all the “My-EAC-Don’t-Work” type of troubleshooting I found on the web but still couldn’t get it to work. Fortunately I found the answer.

After some major googling and searching various forums on the web, I found a link that said something about programs like Daemon Tools and Alcohol 120% causing issues with EAC. The reason is that an outdated SPTD driver that these programs use may cause problems with the ASPI that EAC uses. To fix this you needed to install the latest version which contains a fix for EAC. I coincidentally had Daemon Tools installed on my computer, so I tried it and it worked! :smiley:

You can download the latest SPTD here: http://www.duplexsecure.com/downloads/

I’m really not sure why this wasn’t a problem in the past, but I think I may have uninstalled Daemon Tools and then reintalled it with an outdated version of SPTD that Windows XP provides. That is probably what caused EAC to not work properly when it came around time to use it again. These are one of those stupid problems that not too many people would know about and it was pure luck that I stumbled upon it in the first place.

Much thanks to everyone and their help. You guys are great.

If ever I have probs with EAC, (rarely), I use Audacity to record then save to wave or MP3… :smiley:

nosam, thanks for coming back to post your resolution.

i just have one question for clarification. were you using the native win32 Interface aspi layer? or does this happen when you check “installed external aspi interface” in the EAC Interface options and use the wnaspi32.dll that you externally download.

i just ask because you should always use the installed external interface, and I wasn’t aware of this bug previously with the external option. (I have alcohol and haven’t seen this problem using this setting)

so i guess my question is you say the outdated SPTD driver may cause issues with the aspi that eac uses…which aspi did you have eac set to use?

not to go off topic but you can’t really compare these 2 programs. the main advantage of EAC is its secure mode test and copy options. audacity is a great program…for editing sound, but woudl not be my first choice as a ripper.

@ reasonsnotrules,
Not my 1st choice either nor comparing the two proggy’s ,just what works for me, occasionally…whatever works right?
trying to help is all!!! :slight_smile:

I am currently using the installed external ASPI interface, with the most current Nero’s wnaspi32.dll file in the EAC folder. I tried both ASPI options in EAC when I was trying to fix my problem. When I tried the native win32 ASPI the CD wouldn’t play at all (the play button on EAC was grayed out, as opposed to the progress bar moving and hearing clicks with the external option :)).

I’m thinking the reason why I had a problem with this is because when I reinstalled Daemon Tools, I had to install the SPTD driver manually in the device manager. My guess is that it installed an outdated version that comes in the Windows XP OS and the Alcohol program you have includes a newer SPTD driver that is compatible with ASPI.