EAC and FLAC I'm stuck

Thanks to the kind folks at this site, I was finally able to get EAC to work with my PX-712UF.

I worked through the Coaster Factor tutorial and am happy to say that I can rip and encode to MP3 with no problems.

Now, I want to encode to FLAC. In all honesty, eventually, I want to encode to FLAC for archival purposes, then encode to MP3 for my iRiver. The folks over at Hydrogen audio are working on something to do both within EAC, but in the meantime, I would like to get FLAC working as flawlessly as LAME.

I downloaded the FLAC installer from:
http://www.mikewren.com/flac/

and would like to use the command line:
–best -T “artist=%a” -T “album=%g” -T “tracknumber=%n” -T “title=%t” %s

in EAC.

Now, my question is what do I need to put and where? I would imagine that the FLAC 1.1.1 front end put an exe somewhere… :confused:

Is there a better source for the .exe?
Is there a tutorial like Coaster Factory for setting up EAC with FLAC?

Any advice is appreciated!!!

Thanks

BTO

Install FLAC first, then check out this site…

http://www.saunalahti.fi/cse/EAC/index.html

for setting up EAC (you have to tell EAC where your “flac.exe” is located, usually it’s under “C:\PROGRAM FILES\FLAC”).

P.S.: This is the command line I use in EAC (best and therefore slowest compression (-8); click here for a complete list of FLAC encoding parameters):


-8 -T "artist=%a" -T "title=%t" -T "album=%g" -T "date=%y" -T "tracknumber=%n" -T "genre=%m" %s

Hmmm,

Let me state what I’ve done so far…

  1. I downloaded a FLAC 1.1.1.zip from RareWares and unzipped to a folder on my desktop called FLAC. I did not see any install files, so I then…

  2. …Downloaded the FLAC front end for 1.1.1 as I mentioned in my previous post and installed (via the Windows interface) to Program Files->FLAC.

  3. I pointed EAC to the Program Files->FLAC\flac.exe file, went to the link you suggested and plugged in your list of switches. Extraction went fine (one beep) then a black screen came up briefly and there were two beeps (encoding finished) but I didn’t believe that encoding could occur in 1 second…and I was right. FLAC had out and out just crashed.

  4. In a thread over at Hydrogen Audio, under lossless codecs, with a thread entitled “flac 1.1.1 crashes with EAC” a similar phenomenon was described. The fix was to “download libmmd.dll from RareWares and moving it to the same folder”.

  5. I did this (put it in the desktop FLAC folder and pointed EAC) and did the same for the Program Files->FLAC folder. No change.

  6. If I double click on the flac.exe file in either folder, I get the same result as when EAC tries to execute… <a brief glimpse of a DOS-like window, then nothing>.

  7. Oddly enough, the FLAC front end seems to encode fine, however, it calls a file located at C:\WINNT\system32\cmd.exe

I think I’m close… :confused:

Thanks,

BTO

Why so complicated when it is so simple?

Delete all FLAC files / folders you have unzipped first.

Download the “FLAC 1.1.1 for Windows with installer” file from the FLAC Homepage. After the download finished, just start the .exe to install the FLAC codec (and the FLAC Winamp / Foobar plugin) on your machine.

Once you successfully installed FLAC, just point EAC to the “flac.exe” (usually under “C:\PROGRAM FILES\FLAC”), and follow the instructions as explained above.

P.S.: It always makes sense to download files from the original source, and not from 2nd party sites.

OK,

I did everything you recommended and I still get the same type of error: a flash of a black screen, then two beeps.

If I execute FLAC via START ->Programs -> FLAC ->frontend, I am successful in encoding the wav files generated by EAC.

BTW, I’m using Windows 2000.

Thanks,

BTO

is the Parameter Passing Scheme on “user defined encoder”? i use EAC with FLAC all the time.

Hi AZIMMORTAL

Here are my settings:

Use external program…: on
Param Pass: User defined encoder
File exten: .flac
Program: C:\Program Files\FLAC\flac.exe
Addl Command line: -8 -T “artist=%a” -T “album=%g” -T “tracknumber=%n” -T “title=%t”

As I mentioned in my other post, it seems that some other people are haveing trouble with EAC and the new 1.1.1.a FLAC release. I tried the fix that was suggested at HA but had no luck.

Thanks,

BTO

You need to add a “%s” to your command line, otherwise it won’t work.

The correct command line in your case is:

-8 -T “artist=%a” -T “album=%g” -T “tracknumber=%n” -T “title=%t” %s

Or just use my command line which I posted in my first post, that will work guaranteed.

:bow:

ER um, I did do everything except add the %s. :o

It is working now.

Do you use FLAC attack or Batrun to enable EAC to do DAE, and encode in FLAC and MP3 concurrently a la Hydrogen Audio?

Thanks again for your patience :o

BTO

I don’t encode in FLAC and MP3 concurrently, but that may make sense in your case, since you want to encode to both (mp3 and FLAC) anyway, as you explained in your last thread.