E: drive inaccessible for LG GSA5163d on Dell Inspiron using XP home

I have an LG GSA5163d drive. It works when I read/burn CDs and I can play a DVD movie in it. I am trying to burn data to a DVD drive and that is where I get the e: drive is inaccessible.

I have a Dell Inspiron 5100 laptop using XP home OS. I have noticed also that the drive - E: changes from DVD to CD sometimes. It says it is inaccessible when I put a dvd data disk in. There are no problems with the driver associated with the LG.

I tried one media brand and then JVC (recommended in the user guide for LG) and it is still doing the same thing.

I tried the USB and IEEE connections and it’s doing the same thing.

I am trying to use Nero - the pack that came with the LG drive. I checked the firmware for the drive and it is up to date - what am I missing?

Is there an updated XP driver? I am not a techie, but I am trying to figure out if this is a Dell problem, XP problem, DVD media problem or LG drive problem.

I welcome your help and I did search the forums for a few hours and couldn’t find anything similar. Thanks!!!